iOS app for OH3?

@NCO , I use VPN on demand function of iOS. U can easily configure it with a text file. Here is an excample:

You can configure, if von connects always, in special WiFi or just at mobile connections.

I tried a few different things and ended up using the WireGuard app on the iPhone. Love it. The peer on the other side is a Ubiquiti ER-X.

No one an idea, how the mainUI could be wrapped into the sitemap? Could it be an option to setup a local openhab cloud instance?

AFAIK this is not possible yet.

Still no MainUI via the IOS Apple App to How is this not a priority seriously. Its disjointed. You have the Android app support it just fine, yet Apple doesnt.

Wasn’t that a consideration PRIOR to building the UI? Seems really odd.

If you subscribe to the TestFlight beta, the new build does offer support for the MainUI.

As for why it’s taken so long, the simple answer is because openHAB is open source, and the developers are not paid. Therefore, they work on whatever they want to, and us users get to benefit from using awesome software for free. I get that it’s frustrating - I’ve certainly been excited to use MainUI on my phone and have actually been running everything in sitemaps even though I switched to OH3 when it was released. However, I don’t have the skills to develop, so I’m just resigned to be a grateful user (and try to help on the forum when I actually have time).

I believe the iOS app had several developers get too busy with their personal and/or work lives to keep contributing, and it wasn’t actively progressing for several months this year. Fortunately, it has been making some forward progress lately, and by joining the beta program you can help identify bugs to help the developers deliver a better release. Personally, I’ve not had any issues with using the MainUI in the beta version of the app and use it daily on my primary phone.

If you want more behind the scenes updates, subscribe to updates on the Github repo.


thank you so much! this is a good way to start! everything seems to work perfeclty, but i cannot access to main ui buttons pointing to external link.
i mean, i have published frontail port 9001 and sitemap to be reachable from outside to my dyndns, but these links are not working.
any idea why?

When using those from inside your network, do you still use your dyndns URL to access them ?
Normally, tiles are configure with internal URL, which won’t work from outside your network.

yes, i’ve decided to use on OH3 UI external DynDNS so it can work both from inside LAN and offside…
i’ve tried to use it from my local computer and also remotely from myopenhab page and both works.
from mobile app when clicked does nothing to page that point to “external url”…

the IOS app Beta works finally fine. First, for whatever reason, I was only able to see the sitemap and Main was showing only a blank screen. But after some time and some restarts and re-entering credentials MAIN UI is now being displayed.
Looks good so far.
Thanks for the work


does anyone know when this beta will be released to production? I am waiting to switch over to OH3 but not before I can use my sitemaps on iOS again.

Thanks a lot!

works perfectly. Just one minor thing: I cannot select a MainUI page as the default sitemap so that it automatically starts with that page. Or maybe it is just me and I am doing something wrong

Is MainUI available now in the apple app?

Only in Testflight version…

Does anyone know when this is going to be released to production?

1 Like

No ETA yet, there are still some other issues to be fixed.


Apart from the possibility to get straight into main UI I’m also missing the seamless transition from remote to local and local to remote connections that the android app has. The android app handles network changes (like moving out of wifi range or enabling/disabling vpn) pretty well. I have to restart the iOS app to adapt to the changed network settings. I just had a look at the issues in the repository and I could not find this issue there however. Is this a known issue or a should I file another issue for that?

Don’t know if this a known issue, so you’d better open a new issue on github.

I assume that it is not an App related issue but iOS specific.
On iOS devices there seem to be SSE problems and it might be the case that the iOS app is affected, too.
See the ticket with all infos here