Issues controlling Fibaro Dimmer 2

I just connected a Fibaro Dimmer 2 which won’t let me control it from openhab 2.2

The thing itself has been detected and created.

When I create an item I tried the following approaches

First I configured the item like

Dimmer  F1_Dimmer  "Dimmer"  (F1_LivingRoom)  {channel="zwave:device:16117d1edc0:node23:switch_dimmer"}
  • the dimmer control appears in the sitemap but has no effect. No particular value is received even though I have dimmed it with the hardware switch and the lamp shines with a medium brightness (a “-” shows that no value has been received) nor does moving the dimmer control has an effect on the brightness of the lamp.

  • moving the dimmer results as the following in the log but has no impact on the lamp

    Item ‘F1_Dimmer’ received command 42
    F1_Dimmer changed from NULL to 42

Then I tried

Dimmer F1_Dimmer “Dimmer” (F1_LivingRoom) {channel=“zwave:device:16117d1edc0:node23:switch_dimmer1”}

(the only change is the 1 at the end as I read in different thread that 1 is recommended but I may have misunderstood that)

  • which actually makes it worse because this result into an error in the log

Item ‘F1_Dimmer’ received command 20
NODE 23: Unsupported multi instance command version: 0.
F1_Dimmer changed from NULL to 20

a) So, how what is the right way to configure the item to control the brightness?
b) Is there channel with which I can just switch on or off the light?

thanks in advance
Stefan


PS: I have read the following threads regarding the dimmer 2 but none of the helped me to understand or fix the problem



Could somebody at least show me your thing configuration and one item configuration for one of your Dimmer 2 setup, so I can compare it to mine?

That could help me to track down my problem.

Thanks a lot,
Stefan

Ok, I finally got it working myself.

  • I upgraded to OH 2.3.0 and the latest Development Branch 2.3.0 of the Z-Wave Binding.

  • I started healing the device but that didn’t seem to help.

  • Then I removed the node and re-added it. To be absolutely sure, I reinitialized via Habmin

  • Finally I add the following items

    Switch  F1_Dimmer_Switch  "Esstisch"  <light>        (F1_LivingRoom)  {channel="zwave:device:16117d1edc0:node23:switch_dimmer1"}
    Dimmer  F1_Dimmer         "Esstisch [%d %%]"  (F1_LivingRoom)  {channel="zwave:device:16117d1edc0:node23:switch_dimmer1"}
    

I also added a Number Item

    Number  F1_Dimmer_Power  "EZ Power [%3.1]"   (F1_LivingRoom)  {channel="zwave:device:16117d1edc0:node23:meter_power1"}

which sometimes work and sometimes doesn’t. I tried to figure out when. As the debugging output actually shows that the value is sent from the device to the Zwave Binding I rather believe it is an issue in the Sitemap View.

Also what is weird is the fact that the dimmer control works. But the number next to the slider is only updated when I reload the screen…

At least I can control the light now…

1 Like