MyBMW Binding

hi weymann can you help to configure my bmw 214d?

thanks in advance Enrico

Checked today and GPS locations are working fine. Maybe the settings are changed due to your BMW maintenance. Please check in your car if the following option is check-marked
Main Menu - Settings - GPS Tracking

I have mainly been using MyBMW app on Android but finally managed to add Remote Command on my OH3 page. I can start climate but it seems that I can’t stop it under OH3. Stopping works on the Android app, though. I’m using the latest jar-file (v3.3). I wonder whether anyone else is having this issue?

EDIT: It seems that Climate-stop works. I just noticed that when closing MyBMW app on the phone and restarting it the actual status is updated.

Hi Weymann,
Thank for your answer.
yes i checked and the Gps Tracking is active (in the my bmw app i can see the position so it works).

look at the attached picture:
say that last teleservice report is 14:12:2021 at 8:44 that is exactly the time of the position that i see in your binding…
so my question is:
Is the car that should send the position… or is me that i have to request the position (on the My Bmw app i should request the position)
With openhab i request the position with:
in the logs i see something like:
2022-04-20 15:07:01.760 [INFO ] [nternal.handler.RemoteServiceHandler] - Execute vehicle-finder with parameters []
2022-04-20 15:07:02.447 [INFO ] [nternal.handler.RemoteServiceHandler] - Remote execution result {“eventId”:“4edd4b47-…”,“creationTime”:“2022-04-20T13:07:02.297648Z”}
2022-04-20 15:07:14.194 [INFO ] [nternal.handler.RemoteServiceHandler] - Remote execution result {“eventStatus”:“PENDING”}
2022-04-20 15:07:25.905 [INFO ] [nternal.handler.RemoteServiceHandler] - Remote execution result {“eventStatus”:“EXECUTED”}
but the position is not updated.
Is it correct the procedure that i’m doing?

Hello, I’m getting a Communication Error when I try to set up my bridge thing. I’m in the US, and it appears OH can’t connect to the api URLs that are in the binding. Here are my logs:

09:55:03.992 [INFO ] [hab.event.ThingStatusInfoChangedEvent] - Thing 'mybmw:account:1234' changed from UNINITIALIZED to INITIALIZING
09:55:03.994 [INFO ] [hab.event.ThingStatusInfoChangedEvent] - Thing 'mybmw:account:1234' changed from INITIALIZING to UNKNOWN
09:55:03.995 [INFO ] [hab.event.ThingStatusInfoChangedEvent] - Thing 'mybmw:conv:1234:440i' changed from UNINITIALIZED to INITIALIZING
09:55:03.999 [INFO ] [hab.event.ThingStatusInfoChangedEvent] - Thing 'mybmw:conv:1234:440i' changed from INITIALIZING to UNKNOWN
09:55:04.442 [WARN ] [ing.mybmw.internal.handler.MyBMWProxy] - Authorization Exception: Name does not resolve
09:55:04.445 [WARN ] [ing.mybmw.internal.handler.MyBMWProxy] - Authorization Exception:
09:55:04.445 [INFO ] [hab.event.ThingStatusInfoChangedEvent] - Thing 'mybmw:conv:1234:440i' changed from UNKNOWN to OFFLINE (COMMUNICATION_ERROR):
09:55:05.995 [WARN ] [ing.mybmw.internal.handler.MyBMWProxy] - Authorization Exception:
09:55:05.997 [WARN ] [ing.mybmw.internal.handler.MyBMWProxy] - Authorization Exception:
09:55:05.999 [INFO ] [hab.event.ThingStatusInfoChangedEvent] - Thing 'mybmw:account:1234' changed from UNKNOWN to OFFLINE (COMMUNICATION_ERROR):
09:55:06.000 [INFO ] [hab.event.ThingStatusInfoChangedEvent] - Thing 'mybmw:conv:1234:440i' changed from OFFLINE (COMMUNICATION_ERROR): to OFFLINE (BRIDGE_OFFLINE)

I have this version of the binding installed:

271 │ Active │  80 │    │ openHAB Add-ons :: Bundles :: MyBMW Binding

Any ideas?

For what it’s worth, navigating browser to doesn’t do anything, and the site where I would log into my account is

Hi, I wonder whether there have been some changes in the API because the status of my car doesn’t seem to be updated whereas the MyBMW app on my Android phone works. MyBMW was updated with some new features.

EDIT: Now the MyBMW binding is working so no problems with it. I haven’t looked at the log-file yet so it may indicate what problems there were earlier today.

Is there a currently a general problem with the MyBMW API? My thing is offline (Status forbidden). evcc receives permanent HTTP 403 error codes. The MyBMW app does work.

I was just about to report the same. BMW just can’t help themselves from making changes all the time.

Same here

Same here - so annoying :frowning:
bimmer_connected reports the same problem http-error 403(forbidden), when logging in to BMW. · Issue #444 · bimmerconnected/bimmer_connected · GitHub

Issue: [MyBMW] Authorization fails · Issue #12840 · openhab/openhab-addons · GitHub

This fix looks good on my side


Do i have do update it manually or comes the fix to ther marketplace version, too?

I checked manually but Marketplace is adapted too. Please check and provide some feedback if it’s working on Marketplace

Actually i still got the forbidden error (even after pause/restart the bridge thing).
Binding seems up to date, i am not sure if it updated automatically?
Do i have to restart openhab maybe?

To be honest I’m not that familiar with Community Marketplace updates. As you can see the kar file was updated today with the newest changes.
Please check restart if it does any changes otherwise you can try manually exchanging the jar / kar in update folder. For me it’s working so far

Restart (simple and with cleaning cache) did not work for me.

I just removed the binding and installed it again in the marketplace. Now it is working again. Upgrade an restart is not enough.
Thanks again for your great and fast support!


Tried it this way, too - and it worked. Thank you!

1 Like

I filed a feature enhancement on the MyBMW binding here:

Bernd @Weymann - what do you think of this?

You need a rule anyway. So you can calculate distance from home everytime the location item is changing and write the result into an Item in your own rule.
In my opinion the binding should only provide data but should not calculate what you can do in rules if you really need it.

You will anyway discover that you need to spend more effort in rules. E.g. you might want to identify if your vehicle is approaching or leaving, doors get unlocked => car stopped, …