Myopenhab.org offline?

offline
Tags: #<Tag:0x00007f6cef601fb8>

(Terra) #1

I cannot access https://myopenhab.org anymore.
https://WWW.myopenhab.org shows the startpage but login and register is not working

br


Myopenhab.org down currently?
(Gordon Geist) #2

https://appbeat.io/status/openHAB


(Robert J. Berger) #3

Yeah, some of my integrations that depends on myopenhab.org seems to be down as well.


(Robert J. Berger) #4

Working now. Anyway to find out what happened?


(Dan Cunningham) #5

All of our servers on our hosting provider linode went offline at the same , i’m not sure yet what happened as they eventually came back on their own. I’m guessing some networking error, but still need to do some digging to be sure.


(Robert J. Berger) #6

Thanks for the update! Hope the hosting provider can give you some more insight.
Rob


(Zolon Farsane) #7

Almost had the wife sold on automation by utilizing myopenhab.org as the tie with alexa… now I am losing that battle. :frowning:


(Paul Miller) #8

I have seen a similar slide in WAF with recent issues with myopenhab cloud and a couple of amazon changes that have made it a difficult sell.
I see that myopenhab.org is once again not available? Or is that me?


(Zolon Farsane) #9

It is working at this moment, but it was down again when I commented.


(Hans-Jörg Merk) #10

There was a scheduled maintenance announced by our provider which should not have service affects, but sadly it had…


(Dan Cunningham) #11

Linode had both of their Cisco edge routers fail in our hosting region.
https://status.linode.com/incidents/wc676nqgnwt7


(Thomas) #12

Offline again? There is only the message “Forbidden” after login. Can´t login :frowning:

EDIT: Ok it works.


(Lovro Šverko) #13

I cannot access myopenhab. Is it offline again?


(Stefan) #14

Good Morning,

Yesterday evening the connection between Openhab and Alexa did not work anymore.
After a short analysis, it turned out that my on premise Openhab instance no longer has any connection to myopenhab.org.
Since I had the same problem last week on Wednesday (after a reboot, everything is fine again), I searched this time more closely.

The log file contains the following:

2017-11-23 21:24:42.360 [INFO ] [io.openhabcloud.internal.CloudClient] - Disconnected from the openHAB Cloud service (UUID = UUID, base URL = http://localhost:8080)
2017-11-23 21:29:32.519 [INFO ] [io.openhabcloud.internal.CloudClient] - Connected to the openHAB Cloud service (UUID = UUID, base URL = http://localhost:8080)
2017-11-23 21:29:37.186 [ERROR] [io.openhabcloud.internal.CloudClient] - Socket.IO error: {}
io.socket.engineio.client.EngineIOException: xhr post error
	at io.socket.engineio.client.Transport.onError(Transport.java:71) [203:org.openhab.io.openhabcloud:2.2.0.201710181101]
	at io.socket.engineio.client.transports.PollingXHR.access$000(PollingXHR.java:19) [203:org.openhab.io.openhabcloud:2.2.0.201710181101]
	at io.socket.engineio.client.transports.PollingXHR$4$1.run(PollingXHR.java:88) [203:org.openhab.io.openhabcloud:2.2.0.201710181101]
	at io.socket.thread.EventThread$2.run(EventThread.java:80) [203:org.openhab.io.openhabcloud:2.2.0.201710181101]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [?:?]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [?:?]
	at java.lang.Thread.run(Thread.java:745) [?:?]
Caused by: java.net.SocketTimeoutException: connect timed out
	at java.net.PlainSocketImpl.socketConnect(Native Method) ~[?:?]
	at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350) ~[?:?]
	at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206) ~[?:?]
	at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188) ~[?:?]
	at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392) ~[?:?]
	at java.net.Socket.connect(Socket.java:589) ~[?:?]
	at sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:673) ~[?:?]
	at sun.net.NetworkClient.doConnect(NetworkClient.java:175) ~[?:?]
	at sun.net.www.http.HttpClient.openServer(HttpClient.java:432) ~[?:?]
	at sun.net.www.http.HttpClient.openServer(HttpClient.java:527) ~[?:?]
	at sun.net.www.protocol.https.HttpsClient.<init>(HttpsClient.java:264) ~[?:?]
	at sun.net.www.protocol.https.HttpsClient.New(HttpsClient.java:367) ~[?:?]
	at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.getNewHttpClient(AbstractDelegateHttpsURLConnection.java:191) ~[?:?]
	at sun.net.www.protocol.http.HttpURLConnection.plainConnect0(HttpURLConnection.java:1138) ~[?:?]
	at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:1032) ~[?:?]
	at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(AbstractDelegateHttpsURLConnection.java:177) ~[?:?]
	at sun.net.www.protocol.http.HttpURLConnection.getOutputStream0(HttpURLConnection.java:1316) ~[?:?]
	at sun.net.www.protocol.http.HttpURLConnection.getOutputStream(HttpURLConnection.java:1291) ~[?:?]
	at sun.net.www.protocol.https.HttpsURLConnectionImpl.getOutputStream(HttpsURLConnectionImpl.java:250) ~[?:?]
	at io.socket.engineio.client.transports.PollingXHR$Request$1.run(PollingXHR.java:206) ~[?:?]
	... 1 more
2017-11-23 21:29:37.220 [INFO ] [io.openhabcloud.internal.CloudClient] - Disconnected from the openHAB Cloud service (UUID = UUID, base URL = http://localhost:8080)
2017-11-23 21:31:10.718 [INFO ] [io.openhabcloud.internal.CloudClient] - Connected to the openHAB Cloud service (UUID = UUID, base URL = http://localhost:8080)

but openhab was not connected.
I was hoping to restart the bundle via the Karaf Console, but did not find a bundle.

Then I saved the Cloud Connector without any changes under Services via the Paper UI.

and see there …

2017-11-23 23:34:09.855 [INFO ] [io.openhabcloud.internal.CloudClient] - Shutting down openHAB Cloud service connection
2017-11-23 23:34:09.869 [INFO ] [io.openhabcloud.internal.CloudClient] - Disconnected from the openHAB Cloud service (UUID = UUID, base URL = http://localhost:8080)
2017-11-23 23:34:10.252 [INFO ] [io.openhabcloud.internal.CloudClient] - Connected to the openHAB Cloud service (UUID = UUID, base URL = http://localhost:8080)

a few seconds later, my openhab was online again.

my openhab is running openHAB 2.2.0 Build #1068.

I hope that helps you?


Myopenhab Socket.IO error, app not working
(Alex) #15

@The-Elk

see also here Link
and here Link2

I also had this error yesterday evening (21:29), too.

2017-11-23 21:24:47.714 [INFO ] [io.openhabcloud.internal.CloudClient] - Disconnected from the openHAB Cloud service (UUID = xxxxx, base URL = http://localhost:8080)
2017-11-23 21:29:17.591 [ERROR] [io.openhabcloud.internal.CloudClient] - Socket.IO error: {}
io.socket.engineio.client.EngineIOException: xhr poll error
	at io.socket.engineio.client.Transport.onError(Transport.java:71) [219:org.openhab.io.openhabcloud:2.2.0.201709152241]
	at io.socket.engineio.client.transports.PollingXHR.access$100(PollingXHR.java:19) [219:org.openhab.io.openhabcloud:2.2.0.201709152241]
	at io.socket.engineio.client.transports.PollingXHR$6$1.run(PollingXHR.java:124) [219:org.openhab.io.openhabcloud:2.2.0.201709152241]
	at io.socket.thread.EventThread$2.run(EventThread.java:80) [219:org.openhab.io.openhabcloud:2.2.0.201709152241]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [?:?]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [?:?]
	at java.lang.Thread.run(Thread.java:745) [?:?]
Caused by: java.net.SocketTimeoutException: connect timed out
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) ~[?:?]
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62) ~[?:?]
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) ~[?:?]
	at java.lang.reflect.Constructor.newInstance(Constructor.java:423) ~[?:?]
	at sun.net.www.protocol.http.HttpURLConnection$10.run(HttpURLConnection.java:1890) ~[?:?]
	at sun.net.www.protocol.http.HttpURLConnection$10.run(HttpURLConnection.java:1885) ~[?:?]
	at java.security.AccessController.doPrivileged(Native Method) ~[?:?]
	at sun.net.www.protocol.http.HttpURLConnection.getChainedException(HttpURLConnection.java:1884) ~[?:?]
	at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1457) ~[?:?]
	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1441) ~[?:?]
	at java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:480) ~[?:?]
	at sun.net.www.protocol.https.HttpsURLConnectionImpl.getResponseCode(HttpsURLConnectionImpl.java:338) ~[?:?]
	at io.socket.engineio.client.transports.PollingXHR$Request$1.run(PollingXHR.java:214) ~[?:?]
	... 1 more
Caused by: java.net.SocketTimeoutException: connect timed out
	at java.net.DualStackPlainSocketImpl.waitForConnect(Native Method) ~[?:?]
	at java.net.DualStackPlainSocketImpl.socketConnect(DualStackPlainSocketImpl.java:85) ~[?:?]
	at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350) ~[?:?]
	at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206) ~[?:?]
	at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188) ~[?:?]
	at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172) ~[?:?]
	at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392) ~[?:?]
	at java.net.Socket.connect(Socket.java:589) ~[?:?]
	at sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:668) ~[?:?]
	at sun.net.NetworkClient.doConnect(NetworkClient.java:175) ~[?:?]
	at sun.net.www.http.HttpClient.openServer(HttpClient.java:432) ~[?:?]
	at sun.net.www.http.HttpClient.openServer(HttpClient.java:527) ~[?:?]
	at sun.net.www.http.HttpClient.parseHTTPHeader(HttpClient.java:781) ~[?:?]
	at sun.net.www.http.HttpClient.parseHTTP(HttpClient.java:647) ~[?:?]
	at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1536) ~[?:?]
	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1441) ~[?:?]
	at sun.net.www.protocol.http.HttpURLConnection.getHeaderFields(HttpURLConnection.java:2966) ~[?:?]
	at sun.net.www.protocol.https.HttpsURLConnectionImpl.getHeaderFields(HttpsURLConnectionImpl.java:283) ~[?:?]
	at io.socket.engineio.client.transports.PollingXHR$Request$1.run(PollingXHR.java:211) ~[?:?]
	... 1 more
2017-11-23 21:29:17.691 [INFO ] [io.openhabcloud.internal.CloudClient] - Disconnected from the openHAB Cloud service (UUID = xxxxxxxx, base URL = http://localhost:8080)
2017-11-23 21:30:20.392 [ERROR] [io.openhabcloud.internal.CloudClient] - Socket.IO error: {}
io.socket.engineio.client.EngineIOException: xhr poll error
	at io.socket.engineio.client.Transport.onError(Transport.java:71) [219:org.openhab.io.openhabcloud:2.2.0.201709152241]
	at io.socket.engineio.client.transports.PollingXHR.access$100(PollingXHR.java:19) [219:org.openhab.io.openhabcloud:2.2.0.201709152241]
	at io.socket.engineio.client.transports.PollingXHR$6$1.run(PollingXHR.java:124) [219:org.openhab.io.openhabcloud:2.2.0.201709152241]
	at io.socket.thread.EventThread$2.run(EventThread.java:80) [219:org.openhab.io.openhabcloud:2.2.0.201709152241]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [?:?]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [?:?]
	at java.lang.Thread.run(Thread.java:745) [?:?]
Caused by: java.net.SocketTimeoutException: connect timed out
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) ~[?:?]
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62) ~[?:?]
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) ~[?:?]
	at java.lang.reflect.Constructor.newInstance(Constructor.java:423) ~[?:?]
	at sun.net.www.protocol.http.HttpURLConnection$10.run(HttpURLConnection.java:1890) ~[?:?]
	at sun.net.www.protocol.http.HttpURLConnection$10.run(HttpURLConnection.java:1885) ~[?:?]
	at java.security.AccessController.doPrivileged(Native Method) ~[?:?]
	at sun.net.www.protocol.http.HttpURLConnection.getChainedException(HttpURLConnection.java:1884) ~[?:?]
	at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1457) ~[?:?]
	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1441) ~[?:?]
	at java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:480) ~[?:?]
	at sun.net.www.protocol.https.HttpsURLConnectionImpl.getResponseCode(HttpsURLConnectionImpl.java:338) ~[?:?]
	at io.socket.engineio.client.transports.PollingXHR$Request$1.run(PollingXHR.java:214) ~[?:?]
	... 1 more
Caused by: java.net.SocketTimeoutException: connect timed out
	at java.net.DualStackPlainSocketImpl.waitForConnect(Native Method) ~[?:?]
	at java.net.DualStackPlainSocketImpl.socketConnect(DualStackPlainSocketImpl.java:85) ~[?:?]
	at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350) ~[?:?]
	at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206) ~[?:?]
	at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188) ~[?:?]
	at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172) ~[?:?]
	at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392) ~[?:?]
	at java.net.Socket.connect(Socket.java:589) ~[?:?]
	at sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:668) ~[?:?]
	at sun.net.NetworkClient.doConnect(NetworkClient.java:175) ~[?:?]
	at sun.net.www.http.HttpClient.openServer(HttpClient.java:432) ~[?:?]
	at sun.net.www.http.HttpClient.openServer(HttpClient.java:527) ~[?:?]
	at sun.net.www.http.HttpClient.parseHTTPHeader(HttpClient.java:781) ~[?:?]
	at sun.net.www.http.HttpClient.parseHTTP(HttpClient.java:647) ~[?:?]
	at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1536) ~[?:?]
	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1441) ~[?:?]
	at sun.net.www.protocol.http.HttpURLConnection.getHeaderFields(HttpURLConnection.java:2966) ~[?:?]
	at sun.net.www.protocol.https.HttpsURLConnectionImpl.getHeaderFields(HttpsURLConnectionImpl.java:283) ~[?:?]
	at io.socket.engineio.client.transports.PollingXHR$Request$1.run(PollingXHR.java:211) ~[?:?]
	... 1 more
2017-11-23 21:30:20.411 [INFO ] [io.openhabcloud.internal.CloudClient] - Disconnected from the openHAB Cloud service (UUID = xxxxxxx, base URL = http://localhost:8080)
2017-11-23 21:31:42.385 [INFO ] [io.openhabcloud.internal.CloudClient] - Connected to the openHAB Cloud service (UUID = xxxxxxx, base URL = http://localhost:8080)

I did a bundle:list , then I identified the cloud service binding (mine = Nr. 219)

then bundle:stop 219
then bundle:start 219

After this cloud-service was up again!


Openhab 2 losing cloud connection
(Salexes) #16

I tried to register on myopenhab.org just now but it won’t let me once i press register I just get an white page with the text “Forbidden”


(Jürgen Baginski) #17

Did you fill in all required information? That would be EMAIL, password, UUID and secret.

[Edit]
I have to apologise!
I just checked the status.openhab.org and the connection to myopenhab, both are working. However when I try to sign in on myopenhab.org I get this “Forbidden page” errr as well!


(rbausdorf) #18

I just tried to register with all information - always got the “forbidden” page.
status.openhab.org says everything is operational.

Update (5 min later): After deleting the session cookies in the Browser, the registration worked.


(ChrisH) #19

Accessing the my dashboard via https://home.myopenhab.org/start/index results in a HTTP 504 Gateway Timeout

Running openHAB 2.2


(Jürgen Baginski) #20

Works for me?