New openHab2 EnOcean binding

HI Tino @flynux,

glad to hear that it works now. So the question is why did not worked the autoassignment of the senderId. I will investigate this.

Hi Dirk @dirkdirk,

thanks a lot for your investigations regarding the cumulativeValue channel. I assumed the same problem. Currently the state pattern is defined as "%d %unit%". However it should be defined as you suggested %.1f %unit%. If you like you could create an issue and a PR in the official repo. The currentFlow channel should have the same problem.

Your log entries for your FABH65S are really strange. I will try to analyse it in the next days, I have sa similar motion detector, however I have not linked the illuminance channel. It seems to me as if the problems arise from this channel.

Best regards

Hi Berti @Bize,

I finally created a PR for D2-50 EEP family. Sorry that it took so long, these EEPs needed a lot of new channels and I did not found time to finish it for OH3.

Best regards

Hi Daniel @fruggy83, I have to open another thread, because for me it looks like that the behavior between OH2 and OH3 is different.
I have a physical RockerSwitch Eltako FT55. In OH2 I was able to add a switch to to Channel A nd B. In OH3 I am not able to do so anymore. It tells me the channel is only for triggers:

So on my FMS61NP I have 2 Classic Device with different senderIDs :-). Both are configured on virtualSwitchA. On one of them I created a Listener. I assume only 1 listener is necessary per physical actuator.
UID: enocean:classicDevice:2bcff03d2a:FMS61NP_1_UpperLeft
label: FMS61NP_1_UpperLeft
thingTypeUID: enocean:classicDevice
senderIdOffset: 4
suppressRepeating: false
sendingEEPId: F6_02_01
receivingEEPId: F6_02_01
bridgeUID: enocean:bridge:2bcff03d2a

  • id: FMS61NP_1_Listener
    channelTypeUID: enocean:rockerswitchListenerSwitch
    label: FMS61NP 1 Listener
    description: “”
    enoceanId: 051430D8

I want to use the listener to change the status of the Classic Device Channel (Light on and Off). In a rule I can react on the Trigger of the FT55. But I cannot set the state on the Listener. I assume I have a knot in my brain. :frowning:
The teach in I did it it after a completely new setup of the Thing and Items, including the listener.

BTW when I press the FT55 it triggers more than one event, e.g. DIR1_PRESSED and DIR2_PRESSED. But this is a different problem I guess.

Many Thanks, Tino

Hey Daniel @fruggy83,
Merry Christmas!

I opened a issue at the repo regarding the state pattern.

I don’t know why, but at the moment the Fabh61 is working fine. Motion and lux are both working, so you don’t need to waste your time and check on that issue.

Issue already solved!


It would be nice if you could implement the FUTH65D for setpoint like via gfvs (and the F4HK14 for checking the state). So it would be possible for me to control my heating via this binding.

Enjoy the holidays and stay healthy,
Best regards Dirk

hi dirk, only two days ago I opened a new thread with the same request:
eltako f4hk14

I thought it could work with the implemented functions and the reason for troubles are my settings… If there is any new variant of the binding I’am open to do testing…

Hi, silent reader here.
With your help and the wonderful binding from fruggy I was able to automate my Eltako devices.
Unfortunately after over a year of runtime the SD Card in my pi got corrupted. (Probably by to much writes.)
So i decided to move the openhab device to a PC and use the PI in the Control cabinet, which is connected to the Eltako Bus via FGW14USB only as a bridge with read only SD card.
Previously i was running openhab 2.4 with the dedicated enocean Binding as a .jar file. (Installation was around October 2019)

Now I moved to openhab and installed the official Binding. (To my understanding stable version of downloadable .jar)
Yet, after installation and reconfiguration to use rfc2217 I’m no longer able to send on the bus.
I can see in the log file that I am receiveing telegrams, yet my predefined telegrams don’t appear on the bus anymore. (I read this by connecting to FAM14 via USB and reading telegrams with winetel. Which has worked just fine in the past, as far as I remember)
My Setup (OPENHAB[NETWORK]<=>RPI3<=> FGW14USB[MODE 6]<=>sensors and actors (FTS14/FUD14/FSB14/FSR14)<=>FAM14[MODE2]<=>PC[WINETEL]

openhab Server:
Bridge enocean:bridge:gtwy "EnOcean Gateway" [ path="rfc2217://",rs485=true,espVersion="ESP2",rs485BaseId="00000001"] {

Thing centralCommand TR_Licht_Decke "TR_Deckenleuchte" @ "DG_Treppenhaus" [enoceanId="0000000A",senderIdOffset=10, sendingEEPId="A5_38_08_01" , receivingEEPId="A5_38_08_01","F6_00_00" , broadcastMessages=true, suppressRepeating=false]
Switch TR_Licht_Decke_Swi "Treppenhaus Licht" <light> (DG_Treppenhaus,gLicht) {channel="enocean:centralCommand:gtwy:TR_Licht_Decke:generalSwitch", autoupdate="false"}
pi ser2net.conf:
3003:telnet:0:/dev/ttyUSB0:57600 8DATABITS NONE 1STOPBIT banner

but openhab shows the following:
using the manual rocker for switching:

pressing the item in the control panel:

So openhab tells me it is sending the request. but nothing happens.
Am I missing something? The configuration hasn’t changed besides sending commands over rfc2217 instead of usb, and using “official” binding instead of “external” .jar binding.

I can’t remeber if sent telegrams of openhab have been equally long before. They seem too long with the ending “FFFFFFFFFF00”
Is it possible that FGW14 filters the telegrams because they are too long?

Any idea would help.
Thanks in advance


I’m using the Eltako but directly connected to the raspberryPI. Although it took a lot of effort, it is working very stable now.
Here an example of the things I have installed:

Bridge enocean:bridge:gtwy "EnOcean Gateway" [ 
     rs485BaseId="00000000", path="/dev/ttyUSB0", rs485="true", espVersion="ESP2" ] {

     Thing centralCommand 02_64_Ld "Dimmer_Keuken_Spots" @ "Woonkamer" [ 
          enoceanId="00000002", senderIdOffset=100, suppressRepeating=false, sendingEEPId="A5_38_08_02", receivingEEPId="A5_38_08_02", broadcastMessages=true ]{
          Type dimmer : dimmer [ rampingTime=25 ] }

     Thing centralCommand 09_6B_Ls "Switch_Verdieping_Gang" @ "Eerste Verdieping" [ 
        enoceanId="00000009", senderIdOffset=107, suppressRepeating=false, sendingEEPId="A5_38_08_01", receivingEEPId="F6_00_00", broadcastMessages=true ]


      Thing pushButton P_W6 "pushButton_woonkamer_5" @ "Woonkamer" [
         enoceanId="00001110", receivingEEPId="F6_01_01" ]

I made an excel to get have the corresponding alignment with the Eltako:

Don’t forget to reboot your system, this costed me a full day of troubleshooting…

Hope this helps

is anyone here using a room operating panel?
I am missing the humidity channel with the EEP: A5-10-12.

There should be a humidity channel, but there isn’t one.

Any ideas how to add the channel?

Thank you!

the problem probably is in the area of the ser2net. If I were you, I’d go with a temp minimal OH installation on a fresh additional SD and try to get direct communication with the FGW14USB working there with the current, official binding-version.
If that works, it is confirmed that the problem is with the remote USB/Pi/ser2net

@Aaron2 Since you are also working with central command can you take a look at my Setup which I posted here:

Having some issues with sender id beeing ignored. Maybe since you have a working setup a hint what I am doing wrong would be great!

Best regards!

Well, I changed my configuartion a little to achieve the same thing but in a different way. I removed the listener channel on my FMS61NP things. No need for that anymore. I created 1 FT55 RockerSwitch thing.
And I created several rules. To listen at the channels and change the state of my FMS61NP items.
@fruggy83 The only thing which confuses me is the EEP in the thing config:

I thought I need to create 1 thing for each DIR, but during my experiments I find out that I need only 1 thing and I can check which DIR was pressed. I this correct or a bug in the thing implementation?
Anyway, for me it is working :slight_smile:

I’m not fruggy but i’ll try to answer you. to keep it short:
If you choose F6-01-01 the press of the UPPER Butten is interpreted as DIR1 (Lower = DIR2), this is default for the Eltako Rocker Switches
If you coose F6-01-02 the LOWER Button is interpreted as DIR1 (Upper = DIR2)

You only need to create one thing for one physical rocker switch with 4 physical buttons, the left rocker (upper and lower button) is Channel A, the right rocker (upper und lower button) are Channel B.

hope this creates some clarity

@Wuehli This explanation is very helpful, at least for me. Many Thanks!!! I am now using only 1 thing for my physical FT55 and I get the information I want. Thanks for the reply.

1 Like

Hi Daniel @fruggy83,

Thanks for the support and development efforts, unerstandably you have a busy schedule.
I will need to start working on the project using Thermokon SR06 with RH sensor this spring.
Is it feasible for you to implement the D2-11-02 EEP within next month?
I presume you have not had the chance to look into this?
I am willing to support your efforts with 200 € donation.

Best Regards,

Hi - I just found this thread. Question:

I am trying out several enocean switches, like the Eltako F6T55B or several Peha switches. Adopting and adding them as things works smoothly, reacting to the trigger events they send does as well. However, I can’t figure out how to identify the button that was pressed.

For example, the F6T55B - see my other thread that I just moved to here - has 6 buttons, where essentially the upper 4 are one device, the lower 2 a second device. Thus, I created two things and some rules, all good. But, the triggers are fired whenever one of the buttons is pressed, and I can, based on the two things, only distinguish between 1-4 and 5-6, but not one specific button.

Same problem I have with the Peha switches.

Thus, I am assuming I am simply missing some information. Looking forward to help!


Hi Tanel @Ratiomatic,

when my current PR gets accepted, I will create a PR for SMACK in the official binding and afterwards another one for the Thermokon devices (EEP D2-11 with all features). However I am not sure about the next release of openhab. If it is too late, we should discuss about merging my changes back to openocean.

I added some new features to the SMACK an D2-11 implementation which are not contained in openocean yet. Automatic teach out upon repeated teach in requests, handle SIG messages to get status about the internal backup battery of the room panel.

Best regards

1 Like

Hi Michael @MaMi

could you please show me your rules for handling the buttons? If you simply want to switch something on or off upon a button press you could also just link the channels to an item and use a profile. On/Off and Play/Pause are already implemented. So if you press a button the profile will send an ON/Off or Play/Pause message to the item.

Best regards

1 Like

Hi Daniel,

sorry for the delayed reply. Attached some of my rules.

Rules 1&2 react on the trigger sent by an Eltako F6T55B when two of it’s six buttons got pressed. (On that, you can also check my thread on the difficulties I had to get that switch work). Both rules simply turn a light on and off currently.

Rules 3-5 react on the trigger sent by a Peha Enocean switch, and open/close/stop some blinds.

However, what I am trying to do is for example:

if a button is only pressed for a short moment, switch a light on. But when the same button is pressed for a longer time, dimm the light up. I was hoping that this would be somehow supported by the binding, similar to how the Philips Hue binding is supporting the Hue Dimmer Switch (screenshot 6).

other example: when a button is pressed only shortly, start moving blinds up. When same button is pressed longer, start rolling the lamellas only.

I am happy to discuss in more detail, maybe also via confcall, if it helps.

1 2 3 4 5

Hi Michael @MaMi,

for the first two rules it should be possible to simply link the channels to your GalerieHelligkeit. However I tried it and since OH3 it is no longer possible to directly link these trigger channels to an item.
BTW @flynux Sorry I missed you post regarding this issue, I will analyse this problem, maybe it is an OH3 issue.

Rules 3-5 cannot be handled by the binding out of the box, as I am not getting these short press/long press messages from eltako rockers. The NodOn soft buttons emit those events short, long and double press.
However it is possible to do it by yourself. You already found a thread about a similar requirement. I already posted some rules there, maybe they give you an idee how to solve your problem. If it is not the case you could pm me and we try to find a solution together.

Best regards