New Velbus binding

Tags: #<Tag:0x00007f5c9f9284b8> #<Tag:0x00007f5c9f928378> #<Tag:0x00007f5c9f928210>

Hi community,

Just to let you know that I created a pull request for a new binding.
This binding provides support for relays, dimmers, rollershutters, push buttons, pir sensors and temperature sensors of the Velbus home automation system (https://www.velbus.eu/).

Regards,
Cédric

5 Likes

Nice, I started developing a velbus binding to but never finished it. I will take a look at your code :slight_smile: and test the binding

Great! Let me know if you see possibilities for enhancements or if you need support for extra modules!

stupid questions but how do you actually add the binding. I follow the guide adding the IOT group. But ,will that install the lastest version and stuff?

To add the latest version of the binding, you can simply drop the binding .jar file in the /openhab2/addons folder.

I droped the .jar fil in the addons folder, but Velbus is not shown in the bindings.
I’ve installed openHab on a PI 3 following the instructions.
Restarted the PI multiple times already. PI is with USB connected to my Velbus system through a VMBRSUSB module.

Any help on how to get this running ? Thanks in advance.

openhab.log shows following about the velbus binding :

2018-05-10 23:29:03.051 [ERROR] [org.openhab.binding.velbus ] - FrameworkEvent ERROR - org.openhab.binding.velbus
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.velbus [225]
Unresolved requirement: Import-Package: javax.measure.quantity

at org.eclipse.osgi.container.Module.start(Module.java:444) [?:?]
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1620) [?:?]
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1599) [?:?]
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1571) [?:?]
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1514) [?:?]
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1) [?:?]
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230) [?:?]
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340) [?:?]

Hi Bert,
This is probably because your are not running the latest snapshot version of openHAB. The binding is already using functionalities that are not yet present in the current openHAB stable build. To use the binding now, you will have to switch your openHAB version to the latest dev snapshot as described here: How To: Switch installed version (stable build to latest dev snapshot) - openhabian.

THANK YOU for finally making it possible to use the velbus system with a proper software!

1 Like

Hi,

I got 2 first-gen vmb4pd modules. Although the vmb8pb was found using the Velbus Binding search, my vmb4pd’s are not found. Any idea on how to fix this?
Can I add them manually using my things file? Any idea how?

tx!
Gert

Hi Cedric,

I finally found some time to pick this up again. Started from a clean new install in my RPI and switched to OH 2.4.0 snapshot (#1408), this brings Velbus binding 2.4.0 snapshot.
Also installed Velserv in the PI.

Velbus bridge shows ONLINE now in the Paper UI Things screen but when I start a search in the Inbox on the Velbus binding, no modules are detected.

Any suggestions to get this working ?

I believe the VMB1TS (temperature sensor) module is not supported? Is it? Plans to integrated also this module in the binding?

Hi

There is a bleeding edge jar file version of the Velbus binding that you can install.

First you will have to fully remove the downloadable version within PaperUI.

All the instructions are here, on the Velbus forum, along with a link to the very latest openHAB2 Velbus binding.

Good luck,

Stuart

FYI

A similar question was asked on this forum, here :-

Thanks for this information.

I managed to change the .jar file. Everything seems still to be working as before, and in the PaperUI scanning the Velbus binding discovered me 1 extra thing, a VMB1BL module. Showing me I did it right I believe.

The 4 different VMB1TS (https://www.velbus.eu/products/view/?id=366816) in my system are not discovered.
Are these modules supported by this version of the binding?

It certainly looks like you’ve done everything perfectly.

I could have sworn that the VMB1TS has been added.

The functionality of a VMB1TS is the same as the Thermostats within the glass panels, so if we’re really lucky, Cédric will be able to work some magic on the binding.

(I do know that he is extremely busy, so it might take him some time)

Cheers,

Stuart

is the velbus intergration via the JAR now compatible with the release 2.4 release or do we need to install the Milestone verison? Using the network bridge etc

Now there’s an excellent question.

I can give it a try on a spare machine, while I ask Cédric.

You can’t do any harm by trying :slight_smile:

Tried it, Still need to install the snapshot version

Hi

Cédric says that it should work :thinking:

I was putting a system together for someone a few days ago and realised that I needed to add the V1 Serial binding before the Velbus binding appeared.

If you use the Karaf console with bundle:list you’ll see if the Velbus binding is “installed” or “active”

bundle:list -s |grep elbus

Without the serial binding, Velbus was showing as “installed”, but when I tried to activate it, it threw a dependency error.

Adding the serial binding got it working without any further fuss.

Does that help at all?

got the same thing, So I moved to 2.5M1

The velbus binding does not work in the new release even not when you add the feature:serial …

That’s strange.

I’m running 2.5M1 and the binding is working perfectly.

Did you load the serial binding from the Karaf console or the PaperUI?

bundle:list show the Velbus binding as active