No Data visible in Widgets /Pages

  • Platform information:
    • Hardware: VMWare / AMD64
    • OS:Debian 10.7.0
    • Java Runtime Environment: (Zulu11.43+55-CA)
    • openHAB version: 3.0.0
  • Issue of the topic: Freshly Setup Openhab 3 Server dont show any values in Widgets like temperate, Badges dont work in pages, Switches dont Work,…
    In alternative UIs like HabPanel everything is OK
  • Please post configurations (if applicable): After Setup OH 3.0.0 based on the tutorial i added some Bindings like Loxone. I created channels, items and the model like descripted. In Item Overview i can see for example the temperature of Loxone Channel, when i click on the item so i can see the card widget i just get an “-” as value. i can switch on the light with the switch item, but it is impossibe to turn off the light again. When i refresh the webside the “slider” is in Off even the Light is on.
    In Event.log i can see the event for turning on the light, but there will never be a event to turn off.
    I searched nearly two days about the reason. I tried it with Firefox, Chrome and Edge Chromium. Always the same problem. I dont get any information in the widgets. I tried it then with the browser on my mobile phone and there everything works as expected, all data is visible. So configuration is OK

The big Question is why i doesnt work on my PC…
I am totally new to Openhab, i tried to search here in community forum but i cant find any information about the problem.

It turns out that my antivirus program (avira Pro) blockes some mime types, what are essential for the widgets => text/event-stream

After i add the Mime Type to the exception list everything is working on my PC too…

I find a website where the problem is descripted.
It seems that the source code of OH3 is not 100% compatible with W3C Standards

So maybe it helps some others too

Greetings Thomas

Well there could be something else to it as well:
I am testing out OH 3 for the moment and have the same problem but:
Chrome on Mac and Safari on Mac does not work. But Firefox on Mac works and Chrome on PC works as well. I am using Sophos AV and it is switched on the whole time.

I use Antivir Pro and even when I disable AV Scan in Task bar it doesn’t work. Antivir has a special Web Protection functionality what is still active even when AV scan is disabled. I have to configure this web protection to exclude the Ip Subnet or DNS Domain of my Home Network or to exclude the Mime Type from scanning.

you can configure it at Security => Security Options => Web Protection => Settings

Then everything is working again.
I get all values, switch and badges are working.

I was totally confused, because the demo website of openhab was working like a charm but with the same browser on the same machine I got problem with my own openhab server.

Maybe there is in sophos a web protection too?

After the configuration change of my AV the Events (Sse) are recognized and processed correctly.

I ‘played’ with OH3 today and didn’t have any problems anymore

Maybe your AV has add-ons/extensions to your browser (Chrome and Safari). Maybe in Firefox not enabled and so its working


Thanks for sharing these news. I have been pulling my hair out trying to figure what was wrong - I have the same issue. I have reinstalled openhab 4 times…:slight_smile:
I also use Sophos - did you find a specific solution with regards to letting Sophos accept it?

1 Like

In case someone else stumbles into this, then the solution for Sophos on Mac is to put the IP of your openhab into the exclusions under “web protection”.
Then everything works - also in Safari:-)


In my case “Decentraleyes” in Firefox was the culprit. Disabling it for my local openhab installation solved the issue.
This plugin uses locally stored libraries to serve webcontent blocking possible data sharing with third (unwanted) parties. It thus acts as a proxy server as mentioned in this post. It pays of to scrutinise your security settings and installed plugins.

I pulled my hair on this issue as well. Multiple reinstallation’s before I stumbled on this post.
Using Kaspersky AV I had to add my local OH3 https address as a Trusted Web Address!!
Now I have data in the widgets.
A big thank you.

1 Like