Notifications through myopenhab no longer appearing on iPhone

A while ago, I noticed that openHAB notifications didn’t seem to be appearing on my phone any more (I only have the one mobile device linked to myopenhab). I finally got around to doing some testing today, and what I’ve been able to determine is:

  • notifications from openHAB are being sent to myopenhab: I can see the list of all the notifications which my OH installation has sent by logging in to myopenhab and checking the “notifications” tab.
  • notifications can also be viewed in the System->Notifications part of the openHAB iOS app
  • when I send a test message to the device through the “devices” list in myopenhab, it correctly appears as a push notification on the phone

It’s as if each step of the communications (openhab → myopenhab notification; myopenhab → mobile device push notification) works perfectly, but myopenhab has forgotten that it should take notifications received from the openhab installation and forward them as push notifications to the device. I haven’t even logged in to myopenhab directly for a very long time up until today, so I have had no opportunity to manually change any settings in myopenhab. Any suggestions for how I might get notifications to be passed through again?

1 Like

Its exactly the same for me.

Strangest thing is, that I get a push when I do test-notifications from myopenhab, but I do not get a push, when I do sendBroadcast within a rule. But the notification appears in the notifications list at myopenhab and on the iOS app.

I tried to delete userdata/uuid and userdata/openhabcloud/secret and restarted afterwards. So I got a new uuid and a new secret generated.
I then used these at in the openhab settings.
Unfortunately this also did not work. It shows up as online again on but no changes in push.
Did not help.

I can confirm I have the exact same problem on all iPhones connected to
Test notifications from myopenhab works but any from sendNotification and sendBroadcastNotification only show in the notification list within the app and not as push notifications.

Same issues here, started noticing the issue 2-3 weeks ago. Both on my phone and my wife’s.

@digitaldan, not sure if you still look into these types of issues. Thought I would tag you just in case.

Exactly same behavior on my own devices. I realized today after weeks not receiving notifications. Are we the only ones having this issue or is it globally affecting?

It seems very widespread but not universal. So far the only comments to the contrary seem to be “works for me”, but there are no explanations for myopenhab’s failure to push the notifications that arrive in the myopenhab notification list, while being perfectly capable of triggering a push notification with a test message entered directly on myopenhab. I suspect there is actually a fault - perhaps a patchy one or one that depends on certain circumstances - at myopenhab, but until someone with low-level access to that system engages with these reports, I don’t think any progress is likely.

There is already someone with low-level access involved, our maintainer for myopenhab

@digitaldan Is there anything you need for further analysis ?

1 Like

I’ll look into today and tomorrow.

1 Like

Ok, so i have no idea why this is happening, there’s not any errors in the logs, and its kinda baffling since we know we receive notification requests and record them in the DB, but we also know notifications push to IOS when using the web interface. The one thing i did notice is all of the cases i have tracked down of people not getting notifications looks like they are attached to one specific node process, we use an IP based hash load balancing algorithm, so socket connections get the same server unless its not available. When using the web interface, you are load balanced differently, and to a different node process then what sockets are connected to, which also might explain why the web interface works. This would also explain why its happening to a percentage of users, and not everyone.

I went ahead and restarted this process, i’m hoping that resolves it.


If it helps … it is working to me now. Any fixes applied ? Looks the magic of my post eairler did the work :grinning:

Didn’t you read @digitaldan‘s post?
He restarted one of our services which seemed to got stuck.

1 Like

Thanks @digitaldan !! The restart worked, I started receiving the push notifications again this afternoon.

Problem solved :slight_smile:

Yes! Thanks!

Its also working for me again since yesterday.

Thanks @digitaldan

I’ve just started experiencing the exact issues described by everyone in this thread. It stopped working just a few hours ago.

Steps I’ve taken:

  1. Checked that notifications are being sent by opening the “Notifications” area in the mobile app (and on They are.
  2. Checked that I can send a notification via the myopenhab web console to my device. I can.
  3. Deleted the app on my phone and reinstalled (thus re-registering for push notifications). This did not help.

I suspect that service has got stuck again! :grimacing:
Can anyone confirm and/or assist me? (I’m quite reliant on these push notifications)

(P.S. I was NOT one of those affected by this issue last week, so I assume a new subset of users has been affected :cry:)

Hmm, i’ll take a look, thanks!

1 Like

Same to me too

Same here. Last one I got was sunday at 19:45.
I can see them in myopenhab and in the app, but I don’t get iOS notifications.

Can people check again? I restarted the rest of node processes assuming there must be a very slow object leak or similar (those processes having been running a very long time) . I can confirm this is working on my phone.