Openhab cloud, push notifications not working

Yes, looks exactly like yours.

App Version is 2.4.56 on iOS 17.0.3

Mine is 2.4.60 - Testflight

My wife and I, both iPhone user, have the same problem. Me iOS 17 and my wife iOS16 and both app version 2.4.56. Everything is checked on in the settings. Also I deleted the app reinstalled it but no luck.

The problem is, that the notifications do not get pushed, when they got triggered by rules.
I can get a push-notification, when I do a test-notification (under devices) on In that case, I get a push-notification on my iPhone.

The notifications triggered in rules appear on under notifications, and also in the app on my iPhone under notifications. But I do not get a push-notification for them any more since a couple of days.

I dont think, that it has something to do with configuration on my phone, because the test notifications are correctly displayed.

Also tried to relink (new uuid and secret) my local openhab with and relink the phone with
Nothing changed. I get the push, when I do a test, but it does not get sent, when you trigger sendBroadcastNotification from within a rule.

So i can not reproduce this unfortunately, and its odd as your phone is obviously getting notifications. Are you using SendNotification or SendBroadcastNotification ? The only thing off the top of my head is the notification is somehow not tied to the user right? Seems unlikely since you see the notification history.

I’ve had this issue in the past and solution back then was to either(don’t remember which one worked in the end):

  • uninstall the app
  • remove all devices from myopenhab(same place where you send test notifications)
  • install app and login the app
  • send notification from openhab instance.
  • use invalid credentials in the app
  • remove all devices from myopenhab
  • use valid credentials(over mobile connection, ie not at home).
  • send notification from openhab instance.
    I went the same route first from updating cloud credentials on the instance and then trying to make it work, but it didn’t either.
    In my case the notifications did appear in the notification-list, but just didn’t pop up even though the settings on the device where correct for showing these.

Ok, so i have no idea why this is happening, there’s not any errors in the logs, and its kinda baffling since we know we receive notification requests and record them in the DB, but we also know notifications push to IOS when using the web interface. The one thing i did notice is all of the cases i have tracked down of people not getting notifications looks like they are attached to one specific node process, we use an IP based hash load balancing algorithm, so socket connections get the same server unless its not available. When using the web interface, you are load balanced differently, and to a different node process then what sockets are connected to, which also might explain why the web interface works. This would also explain why its happening to a percentage of users, and not everyone.

I went ahead and restarted this process, i’m hoping that resolves it.


As also replied in the other ticket ( Notifications through myopenhab no longer appearing on iPhone ) it looks like the restart did help.

Thank you!

I’ve just started experiencing the exact issues described by everyone in this thread. It stopped working just a few hours ago.

Steps I’ve taken:

  1. Checked that notifications are being sent by opening the “Notifications” area in the mobile app (and on They are.
  2. Checked that I can send a notification via the myopenhab web console to my device. I can.
  3. Deleted the app on my phone and reinstalled (thus re-registering for push notifications). This did not help.

I suspect that service has got stuck again! :grimacing:
Can anyone confirm and/or assist me? (I’m quite reliant on these push notifications)

(P.S. I was NOT one of those affected by this issue last week, so I assume a new subset of users has been affected :cry:)

I can confirm the same issue you’ve reported, and I’ve taken the same three steps you’ve listed.

The same for me. Everything works apart from push notifications in my Iphone

Works now - 9 Nov 2023. Thank you!

Greetings, I’ve been having the push notifications not working for about 3 days now. I’ve done all the troubleshooting noted above and can get messages when sending from the myopenhab UI. Could someone cycle the process?

Working now. Thanks!

I began having this issue since upgrading to 4.1.0.M4. Going back to 4.1.0.M3 did not fix the issue, so may be unrelated to upgrade.

  • Notifications are in the OH app. Not producing pop up on iPhone

  • Sending notification from produces pop up.

  • Uninstalled/Reinstalled app

  • Restart OH and server

  • Deleted all devices at myopenhab

I started to have issue since yesterday, can view all messages on, can send test message from to my iPad and iPhone w/o issue.
However notification from automation doesn’t work

Good to know I am not the only one.

Hi There, I’m facing the same issue as of now. could there be the problem occuring again?

:sob: It also fails with my iPhone and iPad, as you all described it:

  • messages from openhab to the could are received (immediately)
  • both devices can get test messages from the cloud
  • in the device app the messages are listed in the messages section

But NO single push notification at the device… It seems that the error is not sitting in front of the devices, but anyway not motivating to waste so much time :frowning: