OH2.5 & OH3.0.1 / OH 3.0.0 Installation fail on Docker & Kubernetes: Artifacts not found

Dear OpenHAB Development-Team,

I have tried to setup a clean copy of OH3.0.2 today - yet the container did not come up and I immediatelly get the following log entries after runtime starts inside the container. Below logs are from a test with OH3.0.1

[ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-persistence-rrd4j, openhab-ui-basic, openhab-binding-astro, openhab-ui-habpanel': Error:
	Error downloading mvn:org.openhab.ui.bundles/org.openhab.ui.basic/3.0.1

The more detailed output looks like this:

Launching the openHAB runtime...
org.apache.karaf.features.internal.util.MultiException: Error:
        Error downloading mvn:org.openhab.ui.bundles/org.openhab.ui.basic/3.0.1
        at org.apache.karaf.features.internal.download.impl.MavenDownloadManager$MavenDownloader.<init>(MavenDownloadManager.java:91)
        at org.apache.karaf.features.internal.download.impl.MavenDownloadManager.createDownloader(MavenDownloadManager.java:72)
        at org.apache.karaf.features.internal.region.Subsystem.downloadBundles(Subsystem.java:457)
        at org.apache.karaf.features.internal.region.Subsystem.downloadBundles(Subsystem.java:452)
        at org.apache.karaf.features.internal.region.SubsystemResolver.resolve(SubsystemResolver.java:224)
        at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:393)
        at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1062)
        at org.apache.karaf.features.internal.service.FeaturesServiceImpl.lambda$doProvisionInThread$13(FeaturesServiceImpl.java:998)
        at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
        at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
        at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
        at java.base/java.lang.Thread.run(Thread.java:834)
        Suppressed: java.io.IOException: Error downloading mvn:org.openhab.ui.bundles/org.openhab.ui.basic/3.0.1
                at org.apache.karaf.features.internal.download.impl.AbstractRetryableDownloadTask.run(AbstractRetryableDownloadTask.java:77)
                at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515)
                at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
                at java.base/java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:304)
                ... 3 more
        Caused by: java.io.IOException: Error resolving artifact org.openhab.ui.bundles:org.openhab.ui.basic:jar:3.0.1: [Could not find artifact org.openhab.ui.bundles:org.openhab.ui.basic:jar:3.0.1 in openhab (https://openhab.jfrog.io/openhab/libs-release/)]
                at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.configureIOException(AetherBasedResolver.java:803)
                at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:774)
                at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:657)
                at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:598)
                at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:565)
                at org.apache.karaf.features.internal.download.impl.MavenDownloadTask.download(MavenDownloadTask.java:52)
                at org.apache.karaf.features.internal.download.impl.AbstractRetryableDownloadTask.run(AbstractRetryableDownloadTask.java:60)
                ... 6 more
                Suppressed: shaded.org.eclipse.aether.transfer.ArtifactNotFoundException: Could not find artifact org.openhab.ui.bundles:org.openhab.ui.basic:jar:3.0.1 in openhab (https://openhab.jfrog.io/openhab/libs-release/)
                        at shaded.org.eclipse.aether.connector.basic.ArtifactTransportListener.transferFailed(ArtifactTransportListener.java:48)
                        at shaded.org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:368)
                        at shaded.org.eclipse.aether.util.concurrency.RunnableErrorForwarder$1.run(RunnableErrorForwarder.java:75)
                        at shaded.org.eclipse.aether.connector.basic.BasicRepositoryConnector$DirectExecutor.execute(BasicRepositoryConnector.java:642)
                        at shaded.org.eclipse.aether.connector.basic.BasicRepositoryConnector.get(BasicRepositoryConnector.java:262)
                        at shaded.org.eclipse.aether.internal.impl.DefaultArtifactResolver.performDownloads(DefaultArtifactResolver.java:489)
                        at shaded.org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:390)
                        at shaded.org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifacts(DefaultArtifactResolver.java:215)
                        at shaded.org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifact(DefaultArtifactResolver.java:192)
                        at shaded.org.eclipse.aether.internal.impl.DefaultRepositorySystem.resolveArtifact(DefaultRepositorySystem.java:247)
                        at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:767)
                        ... 11 more
        Caused by: shaded.org.eclipse.aether.resolution.ArtifactResolutionException: Error resolving artifact org.openhab.ui.bundles:org.openhab.ui.basic:jar:3.0.1
                at shaded.org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:413)
                at shaded.org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifacts(DefaultArtifactResolver.java:215)
                at shaded.org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifact(DefaultArtifactResolver.java:192)
                at shaded.org.eclipse.aether.internal.impl.DefaultRepositorySystem.resolveArtifact(DefaultRepositorySystem.java:247)
                at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:767)
                ... 11 more

I can browse to https://openhab.jfrog.io/openhab/libs-release so can generally connect, yet I do not know what to look for :slight_smile:

Same effect for OH-3.0.0 and OH-3.0.2 - cannot get anything done since installation of all addons seem to fail or be blocked by the already failing attempts (not sure).

Note: sounds familiar to this previously reported [Issue](https://community.openhab.org/t/solved-urgent-help-openhab-in-docker-container-fails-installing-bindings-but-internet-connection-works/118806)

Is there anything generally down / not working today? Only a problem on my end? I am out of ideas and happy fpr any help!!

I had the same experience a few days back. You can find my struggle and my ‘solution’ here

1 Like

Same with 2.5… something appears to be broken!

Found another one 15d ago directing to some planned downtime / maintenance:

https://community.openhab.org/t/solved-oh2-5-12-error-downloading-mvn-org-openhab-ui-bundles-org-openhab-ui-paper-2-5-0-2-6/120726/4

If so: would be great if these could be published (as long as planned) on the community pages (sorry if I missed an announcement)

Thx
Jens

Have you seen this one, particularly later paragraphs? It’ll soon be May 1st.

Thanks for the reminder @rossko57, yet: why does 3.0.2 not work either then? And we still have a couple of days until May 1st :frowning:

I don’t know. Do you mean “3.0.2 doesn’t work” or “3.0.1 doesn’t upgrade”? It depends where you start from.

I just tried again installation from scratch not migration. I got 3.0.2 installed this time and added first binding: success.

Tried 3.0.1 a couple of minutes earlier, did not work.

I tried 3.0.2 as well and was succesfull