openHAB 2.0.0 Release Candidate

All,

We have published a Release Candidate of openHAB 2.0.0 on Bintray and via APT repo.
Please help testing it - if you come across critical or blocking issues with it, please report them asap.
The focus should be on the core runtime/distro - it is clear that different add-ons have different levels of quality and some are still buggy and under heavy development; I plan to do 2.0.x patches regularly, which will automatically become available to the 2.0.0 distro. Likewise, new bindings (that are still in the review queue and not yet merged), will be added regularly and become available to all users.

UPDATE: What I had forgot to mention: Major work is being put into the documentation, but as this is a huge topic, we require your help! If everybody from the experienced openHAB users could pick one of these open documentation issues,, we could be sure to have decent documentation ready for the launch of openHAB 2! So please help us as good as you can. :slight_smile:

Best regards,
Kai

26 Likes

Excellent News!

Downloading and installing now :slight_smile:

Just a note for other Bintray Repo users: Use the openHAB 2 Beta Release (not snapshot) Repository to access the OH2RC1 Release (deb http://dl.bintray.com/openhab/apt-repo2 testing main)

For more details, see here:
http://docs.openhab.org/installation/linux.html#package-repository-installation (@Kai this needs some small updates to reflect the RC1 release and single distro info :))

&

Also, remember that there is no more online or offline versions, just openhab2 package, since:

So, to get the RC1, you need to do apt-get install openhab2 from the testing Bintray repo

2 Likes

What about the Addons for Windows installation? Do I still have to download it from Jenkins?

For Windows: You can grab them from Bintray (here: https://bintray.com/openhab/mvn/openhab-distro/2.0.0.RC1). Everything that you need is there (both the RC1 zip file as well as the addons)

For Linux: You can still use the Bintray Repo and grab the addons using apt-get as @Benjy explains in this post:

I have moved away from the Jenkins (APT) Repo and on to the Bintray Repo since last week so I am not sure about Jenkins… it should work in the same way

Here is my report after installing and testing openHAB 2.0 RC1.

Except few non blocking issues that only occurs after the initial startup, this version is working well for me.

The only issue I can mention concerns only the first startup of openHAB that does not lead to what you have setup in your file addons.cfg. My addons.cfg file contains this:

package = standard
remote = false
ui = paper,basic,classic

After the first startup and after waiting a certain amount of time, HABpanel was installed and Classic UI was not, which is not what I requested. An issue was already opened for that issue. Note that after a restart of openHAB, then HABpanel is uninstalled and Classic UI is installed.

Just after the first startup, I can see another strange thing, in Paper UI, “Access Remote Repository” is ON while I asked it to be OFF in addons.cfg. One time again, restarting openHAB solved this issue.

So, you have just to know that the first time you start openHAB, we will not have exactly what you expect but you will have it after a restart.

In the userdata folder, we now have a “log” empty directory in addition to the usual “logs” directory. Is it expected ?

Other minor thing: I can find such log entries in my file events.log while I would expect them more in openhab.log. Is it expected ?

2017-01-17 19:33:22.018 [ExtensionEvent            ] - Extension 'binding-hue' has been installed.
2017-01-17 19:33:22.081 [ExtensionEvent            ] - Extension 'voice-voicerss' has been installed.
2017-01-17 19:33:22.092 [ExtensionEvent            ] - Extension 'binding-weather1' has been installed.
2017-01-17 19:33:22.111 [ExtensionEvent            ] - Extension 'transformation-regex' has been installed.

I just install OH2RC1 on Windows and I don’t get this log subdirectory… just the normal logs one.

From what I see, these are ExtensionEvent type, so it seems normal to appear in the event.log

Anyway, I think (imho) that we should use/open new threads for issues and put in the title the version that we are running (e.g. OH2RC1). This thread is for the major announcement of OH2RC1, so I propose to keep it clean :slight_smile:

Installation on a RPI2 in my case:

pi@raspberrypi2:~/openhab/userdata $ ls
cache  config  etc  jsondb  kar  log  logs  persistence  tmp  voicerss
pi@raspberrypi2:~/openhab/userdata $ ls log
pi@raspberrypi2:~/openhab/userdata $ ls logs
events.log  openhab.log
pi@raspberrypi2:~/openhab/userdata $

Expected: no
Known: yes
:slight_smile: https://github.com/openhab/openhab-distro/issues/383

1 Like

Hi All
I try to install openhab2 RC1 via apt on RP2 but when I run systemctl start openhab2 i get only
root@raspberrypi:/opt# systemctl status openhab2
â—Ź openhab2.service - LSB: openHAB2 server
Loaded: loaded (/etc/init.d/openhab2)
Active: active (exited) since Wed 2017-01-18 16:54:12 UTC; 1min 4s ago
Process: 2435 ExecStart=/etc/init.d/openhab2 start (code=exited, status=0/SUCCESS)

Jan 18 16:54:12 raspberrypi openhab2[2435]: Starting openHAB2 server: openhab2.
Jan 18 16:54:12 raspberrypi systemd[1]: Started LSB: openHAB2 server.
Jan 18 16:55:00 raspberrypi systemd[1]: Started LSB: openHAB2 server.

and I can’t connect to server on port 8080
when I manually run start.sh from /usr/share/openhab2 i get error

Error occurred shutting down framework: java.io.FileNotFoundException: /var/lib/openhab2/etc/custom.properties (No such file or directory)
java.io.FileNotFoundException: /var/lib/openhab2/etc/custom.properties (No such file or directory)
at java.io.FileInputStream.open0(Native Method)
at java.io.FileInputStream.open(FileInputStream.java:195)
at java.io.FileInputStream.(FileInputStream.java:138)
at java.io.FileInputStream.(FileInputStream.java:93)
at sun.net.www.protocol.file.FileURLConnection.connect(FileURLConnection.java:90)
at sun.net.www.protocol.file.FileURLConnection.getInputStream(FileURLConnection.java:188)
at org.apache.karaf.util.config.PropertiesLoader.loadPropertiesFile(PropertiesLoader.java:150)
at org.apache.karaf.util.config.PropertiesLoader.loadIncludes(PropertiesLoader.java:190)
at org.apache.karaf.util.config.PropertiesLoader.loadPropertiesFile(PropertiesLoader.java:173)
at org.apache.karaf.util.config.PropertiesLoader.loadConfigProperties(PropertiesLoader.java:71)
at org.apache.karaf.main.ConfigProperties.(ConfigProperties.java:205)
at org.apache.karaf.main.Main.updateInstancePidAfterShutdown(Main.java:226)
at org.apache.karaf.main.Main.main(Main.java:191)

Maybe related to

Many thx It works :slight_smile:

1 Like

I noticed that my raspberry pi just received a new Java update:

jdk-8u121-linux-arm32-vfp-hflt.tar.gz

Perhaps wise to do some regression?

1 Like

Hello,

I think I just installed it from the previous beta5 version but I am not quite sure it worked because after installing (all scripts looked ok) when I type the following command:
ssh openhab@localhost -p 8101
with password habopen
I get the following:
__ _____ ____
____ ____ ___ ____ / / / / | / __ )
/ __ / __ / _ / __ / // / /| | / __ |
/ /
/ / // / __/ / / / __ / ___ |/ // /
_/ ./_// /// /// |/_____/
/_/ 2.0.0.b5
Release Build
It is normal? it there another way to check the version that is installed?

Thanks

You are still on Beta 5.
To get RC1 you should do:

sudo apt-get update
sudo apt-get install openhab2

Using the Bintray testing repository:

wget -qO - 'https://bintray.com/user/downloadSubjectPublicKey?username=openhab' | sudo apt-key add -
echo 'deb http://dl.bintray.com/openhab/apt-repo2 testing main' | sudo tee /etc/apt/sources.list.d/openhab2.list

http://docs.openhab.org/installation/linux.html#package-repository-installation

1 Like

Is this the right version for RC?

                     __  _____    ____      

____ ____ ___ ____ / / / / | / __ )
/ __ / __ / _ / __ / // / /| | / __ |
/ /
/ / // / __/ / / / __ / ___ |/ // /
_/ ./_// /// /// |/_____/
/_/ 2.0.0-SNAPSHOT
Build #693

No. You are currently on the Snapshot (#693) version
To switch from Snapshot versions to the testing versions (Beta, Release Candidate) you need to use another apt package repository.

Follow these instructions to go from Snapshot to RC1 (they also apply to your case):

(before, you need to switch repositories by modifying /etc/apt/sources.list.d/openhab2.list and using the testing repo):

wget -qO - 'https://bintray.com/user/downloadSubjectPublicKey?username=openhab' | sudo apt-key add -
echo 'deb http://dl.bintray.com/openhab/apt-repo2 testing main' | sudo tee /etc/apt/sources.list.d/openhab2.list

OR

you could stay on the snapshot apt repository and perform an upgrade to get the latest snapshot
Make sure that you have switched to the new bintray snapshot repo (don’t use the older snapshot apt repository at cloudbees)

wget -qO - 'https://bintray.com/user/downloadSubjectPublicKey?username=openhab' | sudo apt-key add -
echo 'deb http://dl.bintray.com/openhab/apt-repo2 unstable main' | sudo tee /etc/apt/sources.list.d/openhab2.list

http://docs.openhab.org/installation/linux.html#package-repository-installation

I am also stuck on b5 somehow. My /etc/apt/sources.list.d/openhab2.list contains the right path but during the apt-get update it seems to be ignored and does not show the full path with */openhab/apt-repo2:

Ign http://dl.bintray.com testing/main Translation-en_GB
Ign http://dl.bintray.com testing/main Translation-en

Any suggestions?

not sure why this is happening…

I would try the following:

  1. Make sure that your /etc/apt/sources.list.d/openhab2.list file contains only 1 line: deb http://dl.bintray.com/openhab/apt-repo2 testing main
  2. Make sure that you have added the openHAB 2 Bintray repository key: wget -qO - 'https://bintray.com/user/downloadSubjectPublicKey?username=openhab' | sudo apt-key add -
  3. apt-get clean, then apt-get update and then apt-get upgrade

Edit: See 2 posts below for the correct solution (apt-get install openhab2) : openHAB 2.0.0 Release Candidate