OpenHabian + Bitron Video Zigbee + IKEA Tradfri

Hey folks,

Hoping you can provide a bit of guidance. I am trying to get my setup to work but not having any luck. Setup is as follows:

  • Raspberry PI 3B
  • OpenHABian v1.5 based on Debian Buster supports RPi4
  • OpenHab 2.5.0-1
  • Bitron Video ZigBee USB-Dongle (Ember EM35x Coordinator/Ember EM35x NCP)
  • Tradfri Smart Plug
  • Tradfri Smart Lightbulb
  • Tradfri Motion Detector

So this week I bought the Bitron Zigbee dongle and Tradfri smart home stuff to try get them working, I went with IKEA as I didn’t want to spend to much to start with.

I had trouble initially adding the Bitron Zigbee dongle as it wasn’t getting detected automatically or when I tried to add it manually. I reboot the Pi and unplugged the dongle and plugged it back in and this seemed to register it.

Since that dongle is working I tried to search for my Tradfri things but its not detecting anything, I tried with the smart plug and the bulb but can’t detect either.

I first tried to pair the smart plug and used a pin in the bottom of the plug to set it to pair while running the pair mode on the zigbee binding but nothing shows up. Tried putting the smart plug right beside the binding just case the distance was an issue but nothing. Found this article as well that had a similar issue but didn’t help

I also tried a smart bulb as well, I copied what was suggested here to switch it on and off 5/6 times but this also had no effect. The instructions that come in the IKEA box only mention to pair with the switch that comes in the box not pairing with the IKEA gateway or anything.

Does anybody have any ideas why the binding wouldn’t be detecting these devices?

I’ll try discover them again tomorrow as its late here now and see if I can generate a log of what might be happening. If anybody has any ideas in the mean time I’d love to hear from you.

You have to turn the light on and off quite often until it goes into pairing mode. I think the device needs like 6 cycles to reset and goes into pairing mode when you turn it back on again. The light bulb starts to automatically adjust its brightness and/or colors when it’s waiting for pairing. If it’s not, it also isn’t in paring mode AFAIK.

If your bulb is discovered but shows up as “Unknown Device” and is unusable after seemingly successful pairing, it might be related to this issue: Problem with fresh Openhab 2.5 / Zigbee / Bitronvideo Ember Dongle / Device Pairing

Thanks for the reply @porst17, it seems the devil is the detail with pairing the devices. I was only switching the light on/off 5 times.

So I’ve got them working this morning but the steps seem to need to happen in a particular order, for anybody else that is trying to get them working this what I did.

Smart Plug
To pair this you need to use the reset hole on the underneath of the plug, the IKEA instructions say to hold this in for 10secs and then release. I tried this multiple times but didn’t seem to work. I read on a reddit to only hold it for 5 secs and release and this seemed to work for me. The step thats important though is that I had to put the smart plug into pair mode first and then start the pairing in OH using the Zigbee binding. If the pairing was started in OH before done on the smart plug it wouldn’t work for me.

Smart Bulb
As @porst17 describes in the above post, the light needs to be turned on/off in 6 cycles. When the bulb is turned on the 6th time from the main switch it will adjust brightness etc. while it’s waiting to be paired. As with the smart plug, I found that bulb had to follow the same steps, it needs to be put into pairing mode before pairing it from OH.

Both of the things initially showed up as “Unknown Device” but when I selected each of them the modal that appeared had the correct name of the device displayed. After adding them they are showing with the correct name and also working as designed.

Hope this is helpful to someone else, shout if you have any questions.

Normally it is better to do this the other way around. The reason is that when you reset the bulb/socket/etc it will start searching for the device. Some devices may give up or slow down as the network will not show that it is allowing joining at this time. If you enable joining first, then when the device is reset and requests the beacon, it will immediately receive the beacon showing that the network is open.

Note though that the binding will only open joining for 60 seconds, so if it takes 30 seconds to reset the bulb (as some bulbs do!), then you need to account for this. I could increase this time a little (the maximum that is allowed is ~4 minutes).

At least it shows that the binding is working with these devices and it’s not just working only for me :slight_smile:

Could you tell me the firmware version of your Bitron Video Coordinator?

You can hopefully see it in PaperUI:

If you can’t see it in PaperUI, it is logged during startup with debug logging enabled:

2019-12-27 19:26:26.378 [DEBUG] [systems.zigbee.dongle.ember.EmberNcp] - EzspVersionResponse [protocolVersion=4, stackType=2, stackVersion=5800]

Thank you!

While it’s interesting to know, I don’t really expect the firmware to be an issue. We routinely use 5.8, 6.4 and 6.7 for testing here and generally they are the same for most standard features and most of the firmware features are configured by the binding during startup.

Still - it’s worth knowing, but I expect all these will likely be the same (I’m not sure if they have a bootloader?).

I should have added - what may be more interesting is the version of the device firmware… Newer devices may want to update keys, and I have this disabled as it was causing a lot of problems with a very large installation where they needed to rejoin some devices and the keys had changed.

The device shouldn’t mind this, but maybe they leave if they don’t get this key update…

I have a brand new Ikea bulb which arrived a few days back. It’s a 8.9W white bulb, and looking at the descriptor information it will be a ZB3.0 device, and it also joined fine here :confused: .

Hi @mrfrh, I am not seeing the firmware in the Paper UI and haven’t had a chance to setup debugging. I’ll get it working tomorrow and check what the firmware is and let you know.

FYI This firmware version display bug was fixed in the latest binding.

I have 2.5 installed, is that the latest or is there a new version?

2.5.1 should have been released today and it should be fixed in that version.

Ok thanks @chris, its late here so I’ll follow up on this tomorrow.

Ok, no probs. I don’t think it’s the issue anyway…

I’ve found something a bit suspicious that may prevent some devices joining so will look at this over the coming days - it might explain why some devices work and some don’t…

1 Like

As Chris mentioned, I don’t think it’s necessary anymore. After some more testing, I’m convinced that my Zigbee issues are not related to firmware version.

Thank you anyway!