openHABian testing

I think I fixed it, please validate (update on start)

it looks different now, I did an upgrate to milestone on a fresh system and enclosed is the log file
putty.log (220.3 KB)

I tried to upgrade to Openhab4, but installation is broken now. I try to setup from scratch. How can I install Openhab3 again with Openhabian?

Read the docs or at least this thread.

What I did is install the latest openhabian which comes up as OH4 and then restored the backup. Depending on you current setup is probably the best approach.


  • restore your original 3.x system (and make a backup via openhabian-config if you are on openhabian)
  • make sure if you are on openhabian that you upgrade to bullseye first
  • only then upgrade to OH4

Other than that please read through this thread about stumbling blocks that could happen during the upgrade.

I figured this out, too. But I didn’t know before that restoring a 3.4.4 backup in OH4 also works. I always thought that a backup must be restored with the same version.

2 posts were split to a new topic: Another failing OH4 upgrade due to buster

10 posts were split to a new topic: OH4 upgrade issue #n

And maybe it is interesting for this thread here, that a fresh install of OH3.4.5 via openHABian 1.8 and clonebranch=openHAB3 leads to an update error similar like

when updating via openHABian-config entry 03.

Given many did the same and it worked for them, your statement, generic as you’ve put it, isn’t correct.
Without proper description, logs and analysis this statement isn’t of use here.

I copied the openHABian 1.8 image to a 32 GB SD card.
In openhabian.conv I changed clonebranch to openHAB3 and java_opt to 11.
Then I put the SD card in an RPi4 with 4GB RAM and let openHABian do it’s magic.

Version:     3.4.5 (Build)

User:        openhab (Active Process 805)
User Groups: openhab tty dialout audio bluetooth gpio

Directories: Folder Name      | Path                        | User:Group
             -----------      | ----                        | ----------
             OPENHAB_HOME     | /usr/share/openhab          | openhab:openhab
             OPENHAB_RUNTIME  | /usr/share/openhab/runtime  | openhab:openhab
             OPENHAB_USERDATA | /var/lib/openhab            | openhab:openhab
             OPENHAB_CONF     | /etc/openhab                | openhab:openhab
             OPENHAB_LOGDIR   | /var/log/openhab            | openhab:openhabian
             OPENHAB_BACKUPS  | /var/lib/openhab/backups    | openhab:openhab

When finally OH3.4.5 came up properly nice and clean I tried to update to OH4 via openhabian-config entry 03 and got this:

+ openhabVersion=
+ cond_redirect apt-get install --allow-downgrades --yes -o DPkg::Lock::Timeout= --option Dpkg::Options::=--force-confnew openhab= openhab-addons=
+ [[ -n '' ]]
+ echo -e '\n\033[90;01m$ apt-get install --allow-downgrades --yes -o DPkg::Lock::Timeout= --option Dpkg::Options::=--force-confnew openhab= openhab-addons= \033[39;49;00m'

$ apt-get install --allow-downgrades --yes -o DPkg::Lock::Timeout= --option Dpkg::Options::=--force-confnew openhab= openhab-addons=
+ apt-get install --allow-downgrades --yes -o DPkg::Lock::Timeout= --option Dpkg::Options::=--force-confnew openhab= openhab-addons=
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Version '' for 'openhab' was not found
E: Version '' for 'openhab-addons' was not found
+ return 100
+ echo FAILED

error.txt (45.8 KB)

Hopefully, this is not incorrect and too generic.

update and try 03 again, mind taking log

… does still not work

error.txt (38.6 KB)

Try again please

… now it worked, thanks.

log.txt (104.8 KB)

I noticed this yesterday:

openhabian@openhabian:~ $ sudo openhabian-config
2023-08-17_21:02:58_CEST [openHABian] Checking for root privileges... OK
/opt/openhabian/functions/menu.bash: line 1: e#!/usr/bin/env: No such file or directory
2023-08-17_21:02:59_CEST [openHABian] Loading configuration file '/etc/openhabian.conf'... OK

So I opened the file, and in the beginning saw:

e#!/usr/bin/env bash

show_about() {
  if openhab2_is_installed; then OHPKG="openhab2"; else OHPKG="openhab"; fi

I will remove the “e” to fix this issue, but I’m wondering if anyone has an idea how this might have happened? I have not had this file opened in a text editor before, I even searched my .bash_history without any hits.

It has been released like this a while ago.

Okay, so I’m not crazy. Thanks! :wink: I wasn’t able to find it in Git history here, and I also thought that this would update automatically to the latest version when openhabian-config updates itself?

Gentlemen, is there a way to fix the problem with USB device detection related to UDEV in openhabian?
The problem is described, among others, here:

and here:

and here:

Will it be necessary to wait for a new version of openhabian based on bookworm?

I don’t know. This is not an openHABian problem, but this is an Open Source project.
So go find out yourself, tell us and ideally provide the fix if there’s one needed in openHABian.

1 Like