[SOLVED] After update from 2.4.0 to 2.5.1 #11 habmin not working

I’m updating my testsystem from 2.4.0 stable to 2.5.1 #11. All is working perfect, great work.

Only habmin is strange and not usable, no menue, only icons. Any idea how to fix it?


Did you try to


Yes tried, does not fix it.

I think this is not the case. I’m on win10 and 2.4.0 is working with all browsers.

After the update HABmin it is not working with any browser.

To test it, I made a fresh installation of openHAB and it is the same. All is working, only HABmin not.

I can remember that I had these problem years ago and cannot remember how I fixed it.

The only error I see on startup is thsi one.

2020-01-10 11:45:39.329 [WARN ] [org.apache.karaf.shell.ssh.Activator] - Error starting activator
java.lang.IllegalStateException: Service not tracked for class interface org.osgi.service.cm.ConfigurationAdmin
        at org.apache.karaf.util.tracker.BaseActivator.getTrackedService(BaseActivator.java:369) ~[bundleFile:?]
        at org.apache.karaf.util.tracker.BaseActivator.ensureStartupConfiguration(BaseActivator.java:154) ~[bundleFile:?]
        at org.apache.karaf.shell.ssh.Activator.doStart(Activator.java:96) ~[bundleFile:?]
        at org.apache.karaf.util.tracker.BaseActivator.run(BaseActivator.java:312) [bundleFile:?]
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_202]
        at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_202]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_202]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_202]
        at java.lang.Thread.run(Thread.java:748) [?:1.8.0_202]

I tried OH 2.5.0 stable and it is the same. HABmin not working well.

If I move back to OH 2.4.0 stable all went well. No clue how to fix it.

If you are a tester running a snapshot you know issues are to be reported on GitHub where they can be resolved. Most users here in the community are not testers and many developers do not use this forum.

It is solved.

I get it to run with Firefox only. No IE11, no Edge shows HABmin correct.

That is a workaround, not a solution. Please report the bug.

Only changing the topic name to “[Solved]” is not really solved.
See the above quote from the topic How to ask a good question / Help Us Help You

And yes I agree with @Bruce_Osborne, it’s not really solved.
This issue will recur for other users on windows.

1 Like

I’ve created a bug at github.

Does anyone know how to see the post #? Sometimes I see comment post #54 solved it, but how to know which one it is?

Info only; I rarely use Habmin.
OH2.5 hosted on Win 7
Habmin fine in Chrome browser
No text labels as in screenshot, with IE11

Info only:
I use it only for Zwave-Admin.

I just poked around and found at least one way. Click the link icon on the post:

You will get a popup.

By the way, is you use that link, strip your username off the end of it.

Also, if there is a solution, in the first post you can click the post number to go to that post.