[SOLVED] After update to openhab 2.5 -> Stopped Dashboard?


after my update to open hab 2.5 i can’t open the dashboard via http://ipadress:8080.

in the log file i can see “Stopped Dashboard”.

why does it automatically stopped my dashboard?

Any other problems reported in the log?
Did you restart openHAB after the update?

i reinstall openhab and got this log:
openhab> log:tail

18:41:51.271 [INFO ] [i.dashboard.internal.DashboardService] - Started Dashboard at http://IP:8080
18:41:51.363 [INFO ] [i.dashboard.internal.DashboardService] - Started Dashboard at https://IP:8443
18:41:59.927 [INFO ] [rthome.model.lsp.internal.ModelServer] - Started Language Server Protocol (LSP) service on port 5007
18:42:11.662 [INFO ] [i.dashboard.internal.DashboardService] - Stopped Dashboard

Did you install openhab2-addons? That is only needed if you will be running OH with no Internet access to install bindings. There is a known bug in 2.5 related to the initial dashboard when addons are installed. We do not expect this to be fixed in a 2.5 release. This bug only impacts fresh installs though, not updates/

There is a workaround though is this is the cause of your issue. After initial package selection stopping the dashboard is expected behavior.

think you, after i install everything new and recover my backup i had exactly the bug problem.

after only install openhab without openhab2-addons the problem was fixed.

Curious. You said update and, in my testing updates from 2.4 worked fine. Only fresh installs were broken.

I have created https://github.com/openhab/openhab-webui/pull/163 as a fix for this - the dashboard is still likely to be deinstalled when the local addons are installed, but it will be automatically back upon a restart.
For everybody wanting to fix an existing 2.5 installation, you can either install the dashboard through the openHAB console with

feature:install openhab-ui-dashboard

or, if you are anyhow using textual configuration, add dashboard to the ui= section in conf/services/addons.cfg:

# A comma-separated list of UIs to install (e.g. "ui = basic,paper")
ui = dashboard,paper,basic

Hope this helps!


Short update: I have fully fixed the issue with https://github.com/openhab/openhab-distro/pull/1041, which also makes the offline installation work as expected. Will discuss with the maintainers, how and when we can release this.

Happened again on update from today.
Solved using your same advice from January.

Was this a fresh install or update?
If an update, what was your old version?

The original issue only affected fresh installs with the addons package.

Happened updating from to

1 Like

I will test that but hope that is not repeatable. :angry: :cold_sweat:
The fresh install 2.5.0 problem was fixed in 2.5.1.

Hey guys, I updated yesterday to 2.5 and my dashboard is gone as well; I am not able to connect to ssh -p 8101 openhab@localhost inside an already established ssh connection onto the raspi and the conf/services/addon.cfg mod did not help because I guess this was only meant for upgrades, right?
Can anyone help? How do I see if the dashboard is missing (apart from the fact that I am not able to connect to :8080 of course…

Thanks a lot in advance! :wave:

  1. You likely upgraded to 2.5.3 The OP upgraded to 2.5.0
  2. If the solution in this thread did not work for you, you have a different problem with similar symptoms. Please start a new thread.

The issue of this thread was confirmed fixed in 2.5.1.

I had 2.5.2-1 with Z-Wave running fine on my RPi3B+ test unit.
Some weeks back I updated to 2.5.3-1 and lost most of the UIs including paper.
Recovered by adding paper to addons.cfg and added more UIs that way.
Today I updated to 2.5.4-1 and lost the :8080 dashboard (from bad to worse).
Tried to recover by adding dashboard and UIs to addons.cfg, but got an error message saying: “Upload of file ‘addons.cfg’ was successful, but error occurred while setting permissions and/or timestamp”.
openhab.log says all UIs were stopped.
Any suggestions on how to recover from this?

I’m having this same issue after updating to 2.5.4, during the install i noticed it had stopped all my dashboards via the log viewer. After multiple reboots, no luck. I can not view 8080, however 9001 partially loads. I went into Visual Studio Code and editted the config file to add ui = dashboard,paper,basic , I can now see 8080 but when i go to anything like paper, i get a blank screen.

Also I can not access openhab-cli console from putty, i get an error now post update. No issues before.

Any help would be appreciated, thanks.

You’re getting following error-message?

/usr/share/openhab2/runtime/bin/client: 247: [: Illegal number:
/usr/bin/java: error while loading shared libraries: libjli.so: cannot open shared object file: No such file or directory

If so, better refer to this topic:

yep , k i’ll follow that thread now :frowning: