[SOLVED] How to delete a dead node from a zwave stick

I want to delete a dead node (of faulty device) from the zwave stick (Aeonlab zstick gen5, or UZB)
When deleting a device from PaperUI -> Inbox what is actually happening?
I’m asking because, the device disappears but keeps coming back when searching for new devices.
This device then causes chatty log messages in the zwave.log file that may lead to unwanted side effects

You need to follow the instructions of your Z-Stick and Device in order to exclude the device from your controller (the Z-Stick)

OH2 will read from the controller the list of included devices and will report them back in the discovery if they still exist in the controller. Deleting the thing from PaperUI will not remove it from the controller memory.

The instructions of the z-wave stick tells to either

  • put the controller into exclusion mode and click the device to exclude it, but the device is dead
  • apply hard reset to the zwave controller , which is not a practical option since I have so may other nodes registered with the stick.

I read here that the Zensys tool can do the job, I want to install it but I can’t find it… Anyone knows where the Zensys tool can be installed from?

I found this: http://docs.incontrolha.com/home/remove-a-failed-device using google :stuck_out_tongue:

Thanks @Dim. I downloaded the tool and followed these instructions and was able to delete the problematic node.

2 Likes

You can also do this from HABmin - there is an option in the thing menu (advanced) called “Remove node from controller”. This will only work if the device has failed - other you also need to use the option “Move node to failed list” (names might be slightly different in the menu, but it should be obvious ;)).

4 Likes

Dear @chris !
Node 3 is broken (the device doesn’ t work anymore).

Tried to set as failed:

Tried to remove node:

When I delete the thing and do a Zwave inclusion again, Node 3 appears again.

Any hints (I am on the Zwave - Binding Version from 8th of Feb.)?
Herbert

I think this means that the controller doesn’t think the device is dead. The controller only allows devices to be removed if it thinks it is not working and the “not found” error means it wasn’t on the dead device list.

Hi @chris!
How can I move it to the “dead device list” --> when trying to mark it as failed --> see screenshot the post above? After 3 or more days, why does the controller not think it is dead (probably because not initialized in the beginning?)? Is there any “hard exclusion” possible or should I try the Zensys tool to delete it.
BTW: if I should open a separate topic, pls just tell me.

Regards,
Herbert

This I can’t answer. I’ve been meaning to ask Sigma this question but have not done so. I’ll raise a question with the ZTS team.

I have the same problem with a z-wave device that refuses to work, and refuses to be removed. In the search it shows up with 3 different node ids! trying to exclude it makes no difference, it always shows up, but none of the three nodes work when I add them. They all show Offline, and in the log it says they are dead. I tried to use HabMin to remove them from the controller, but they still show up in the search. Any ideas?

Zensys tool did worked for me try it hope it help

Please try the binding to see if that works (ie the latest version). We spent some time recently making sure that the binding is doing the same thing as the Sigma tool, so it should also work just fine.

Hi,
after I added the “ABUS Z-Wave HomeTec CFA3010” door lock to the Z-Wave database - thanks to Chris, Bruce and suhui :slight_smile: - I have to remove two “ghost” nodes (nodes 10 and 11) from my Aeotec Z-Wave USB stick. These ghost nodes were generated BEFORE successful inclusion of the door lock.
Because I’m running a linux system, I tried to use the ZWave tools “ZenSys” and “HS3” in a virtual machine and tried to delete the ghost nodes. But without success. The software asks me to initialize the exclusion procedure by pressing the button - which is impossible because I included the door lock successfully. And starting the exclusion to my mind will delete the door lock instead of the ghost knodes.
I tried the binding to delete it from the ZWave USB stick by

  • Set the “ghost” node into editing mode
  • Enabled “Set device as FAILed”
  • Saved the changes

As I read in certain threads the ZWave USB stick will only remove failed I hoped that this marked the “ghost” node as failed in the ZWave USB stick’s internal database.
So in the next step I

  • Set the “ghost” node into editing mode again
  • Enabled “Remove device from controller”
  • Saved the changes again

Then I deleted the xml files which where generated during inclusion of the “ghost” nodes from the {userdata}/Zwave folder.
But every time I’m searching for new ZWave things the “ghost” nodes I thought that were deleted appear again.

So is there working solution or work around for this problem?

I’m running openHAB2 v2.5 on a Raspberry Pi 4.

Thanks for help :slight_smile:

I downloaded and installed open-zwave-control-panel (OZWCP) on my RPi. It’s still a hassle and sometimes doesn’t listen. And you have to wait a while until the names appear. The ones that don’t appear probably are the ghost nodes :slight_smile:

Another tip for those using Rpi and Z-way.me onboard controller is to download their software and use it to maintain the z-wave network. Download the .deb package and unpack z-way-3.0.6_armhf.deb (or the version you got), and then unpack data.tar.xz. Copy the z-way-server folder in /opt somewhere and run z-way-server (no root needed). Don’t forget to stop openhab first :slight_smile:

Made a simple bash script to get the job done easier. Change the path at the end of the script to reflect your installation. Just press ctrl+C to abort the script, the script will catch it and restart OpenHAB.

#!/bin/bash

stty -echoctl # hide ^C

# Handle SIGINT to stop script
abort() {
    tput setaf 1    
    printf "Stoping Z-way server..\n"
    printf "Starting OpenHAB server.."
    sudo systemctl start openhab2
    printf "\n"
    tput sgr0
    exit 0
}

trap 'abort' SIGINT

tput setaf 1
printf "Stoping OpenHAB server..."
sudo systemctl stop openhab2
printf "\n"
tput sgr0
cd z-way-server/
./z-way-server

Hi zynex

I tried using Z-Way Server, but I was not able to delete the devices.
The “remove” butten is greyed out. How did you manage to remove devices?
Additional I only can see 2 of my 3 dead devices.

Afaik you have to mark them node as “failed” before.
I do not have the software installed anymore, but this is what I remember from some weeks ago.

Regards,
Thomas

I’m pretty sure I did this more than once, as I tried in OH to mark as failed and to “remove from controller”.
I ended up by just ignoring this nodes in OH. Maybe they have to be added as thing and marked as failed to not be greyed out in Z-Way Server.
However currently I don’t like to try to remove this devices anymore. I lost to much time already.

Thank you anyway for your input

Regards,
Levin

I finally managed to remove the devices using z-way-server (on RPi 3+, openhabian and raZberry/Z-way.me controller.

To make it clear for everyone who is struggling, here is the detailed procedure:

  1. Install zway server (something like --dpkg -x z-way-3.2.0_armhf.deb “folder-location”–
  2. (In OH set device as failed and remove it, maybe this step is not needed. But I recommend to at least remove the thing)
  3. Stop OH Service (see zynex’s post)
  4. Start zway-service (go to install locateion and type “./z-way-server”)
  5. connect to z-way using web browser “http://your-oh-server-ip:8083
  6. Go into ExpertGui Mode and follow the folloing steps:
  • Hover on “Network” and klick on “Control”
  • In the Network Maintenance Section select your device Node ID and click “Mark Battery Device as failed
  • wait 30 sec as stated until the job is done
  • Choose again your dead nod and click again on “Mark Battery Device as failed”
  • Now you should be able to select the Node ID at the top of the “Network Maintenance” Section and click on “Remove failed Node”
  • In the “Device Management” Section it should state Device # “ID” as excluded
  • Remove the device from OH Inbox if needed. It should not show up again while scanning.

I hope this helps.

Best regards
Levin

1 Like