(Solved)nanoCUL not responding to OH2

I’m trying to use a nanoCUL(433) on my Raspi2 running openHABian with OH2.2.
The system was using a CUL(866) as device “ttyACM0” with no problems. Now I tried it with the nanoCUL as device “ttyUSB0” without success.
I checked with minicom that the device is correct and that the nanoCUL is sending the commands.
I put in the correct device definition into the culintertechno.cfg
I changed the file /etc/default/openhab2 to include:


In the logs (with DEBUG set for org.openhab.io.transport.cul) I get:
When starting OH

2018-01-02 21:59:34.558 [DEBUG] [io.transport.cul.internal.CULManager] - Registering class org.openhab.io.transport.cul.internal.network.CULNetworkHandlerImpl for device type network
2018-01-02 21:59:34.566 [DEBUG] [org.openhab.io.transport.cul ] - BundleEvent STARTED - org.openhab.io.transport.cul
2018-01-02 21:59:34.639 [WARN ] [io.transport.cul.CULLifecycleManager] - CUL config is NULL, doing nothing
2018-01-02 21:59:34.653 [DEBUG] [io.transport.cul.internal.CULManager] - Trying to open device serial:/dev/ttyUSB0 in mode SLOW_RF
2018-01-02 21:59:34.656 [DEBUG] [io.transport.cul.internal.CULManager] - Searching class for device type serial
2018-01-02 21:59:34.690 [DEBUG] [internal.serial.CULSerialHandlerImpl] - Opening serial CUL connection for /dev/ttyUSB0

When trying to send a command

22:10:04.613 [DEBUG] [sport.cul.internal.AbstractCULHandler] - Requesting credit report

…but the command isn’t send!

I feel really ashamed to be asking this, although I could help others on topics which seem to be same!

Is there an easy way to check during runtime of OH2 wether ttyUSB0 is usable or not as a serial device?

Since I can’t get it to work I’m starting with a new openhabian installation.
It doesn’t work either on the clean system???

No joy so far.
I checked this Raspi2 with my other CUL (which is connected as ttyACM0) and this one is working, but still nothing is send nor recieved by the nanoCUL connected at ttyUSB0.
The noticable difference in the logs is that the ttyACM0 connnected CUL reports its credit report back to openHAB.
And to make it clear again, the nanoCUL is working on the system when using it through minicom (which is closed while trying to send with openhHAB).

I’m clueless!

Probably a permission issue.
Did the user who runs openhab is in the dialout group?

Otherwise the check with the other CUL (ttyACM0) would have failed.

I didn’t do this one:

Also, did you check the group?
Is ttyUSB part of dialout or tty and is oh user also part of that group.

What does your IT config look like?

crw-rw---- 1 root dialout 188, 0 Jan 5 20:03 ttyUSB0

And all others settings being different would prevented the positive check with the other stick.

I’ll do another check without the

OThe test without the EXTRA_JAVA_OPTS failed also, however after putting them back in And doing a system restart it finally worked.

To sum it up I have changed the serial settings through the openhabian config tool (selection 35) using the first (disable console) and third ( Add common serial ports…). I manually added the ttyUSB0 also to etc/default/openhab2.
Do not forget to do a complete restart!


1 Like

Seems different from what I did but glad it works.

I am curious, could you check for me what the ttyUSB0’s group/access rights are now that it is working?
I wonder if “-Dgnu.io.rxtx.SerialPorts=/dev/ttyUSB0” and a reboot changed the rights?

If so, I might try the /dev/serial/by-id method too.

No, the group settings did not change at all!
Actually, I’m not sure anymore why it worked at last, since I’m trying to move the nanoCUL to my productive system (Raspi3) and am observing the same problem again.

I got my nanoCUL to work on:
OH2.1 on my pi2
Fresh reinstall on OH2.2 on my pi2. (I only copied my intertechno config
Moved OH2.2 SD to RPi3.

Shall we compare config files?

1 Like

Found it by comparing my Raspi2(working) with the Raspi3(not working), after removing the disabeling of BT (probably done using openhabian-config and doing all selections under selection 35) AND a restart it finally worked.
One thing remained, although not needed for me, I could only get one stick to work while NO other was connected. How can you work with two CUL-sticks?

Thanks for standing by me.

I still need to double check that the send CUL is really usable, but based on the logs it would like it is being recognised well.

By the way - could you teach me how to scan RF signals being transmitted?
I want to catch the signal my 433Mhz door bell button sends.


In order to capture the signals you need to use the CUP with screen or minion, not with openHAB. The messages will be shown when received.

Sure, but could you teach me a bit more to it please?

There is nothing more, the message you get displayed is what’s being sent, only the presentation might be different ( not binary nor Manchester code).

but how to make the CUL display anything?
I can open the serial, that is no problem, but do I need to give it a command to then make it spit out what is it receive to me?

You wanted the recieved messages to be displayed, of course you need to send something while trying to recieve. In your case: RING TO BELL. But please silently, I want to sleep now!

Lol, no what I meant is do I have to send a command to the nanoCUL to make it echo the RF signals it receives?