[SOLVED] Zwave, unknown device NEO Coolcam power plug

I’m running now on openhab3. I have 2 NEO Coolcam power plug, and they work fine. Yesterday I received 2 new ones, they look only a bit different but both are not recognized, it says unknown device.

Maybe there’s a new firmware installed? In Openhab3 I don’t know where to find the information about the firmware version or Type/ID

I’ve heard that the NEO Coolcam devices can be flaky, so you may need to wake them many times to get them to be recognized. If not, here’s the guide for checking and updating the database.

Changes will be merged into a future snapshot binding, which you can install manually.

Note the latest comment about how to make the script work in OH3.

The first link says:

“Devices are identified in the database by 4 pieces of information that are provided by the device during the initial discovery process.”

Where can I find

Manufacturer ID
Device Type
Device ID
Firmware version

in openhab3?

It’s in the userdata/zwave folder.

1 Like

Thank you, found that folder. But the 2 new wall plugs are not listed, in openhab I get a node number, and it says online when it is online, and offline when I pull it out, but unknown device and in the zwave folder both are missing.

You might need to delete the thing and try readding it to get it to initialize. I’ve had to do that multiple times with some battery-powered devices.

I have never heard of a battery operated power plug :face_with_raised_eyebrow:

I have found that for some of my cheap coolcam devices they actually needed to be factory reset before they would include properly into the network. If you are going to do that , try excluding them first in the hope you do not end up with zombie nodes in your network.



That being said, you’ll appreciate this nugget from a CES announcement earlier today.

Signify is releasing a Philips Hue wall switch module that upgrades existing switches to smart units. The add-on not only keeps lights available regardless of the switch position, but lets you specify what happens when someone toggles that switch.

It’s also battery-powered, so you’ll need to dismantle your switches every five-plus years to keep the module running.

I’m assuming that this was done so that it doesn’t need a neutral wire, and that Signify’s engineers failed to adequately explain it to the people who wrote the press release.

If it fits in the electrical box, what happens with those older grounded metal electrical boxes? They should block the RF signal pretty well…

1 Like

That was it, factory reset and after that it worked. Thank you.

I hope you have better luck with Neocam than me. I have already replaced one sensor due to being a battery hog. I am getting ready to replace another because at times it fails to detect motion.

Actually I like Neo Coolcam, I had already 2 power plugs for 2 years now, I never had a problem.

I have as well 2 power plugs from fibaro, and they need to be reset from time to time because they stop working.

I have not used my power plugs much but I suspect weak radio reception. The plugs I used with the Christmass tree lights worked much better than the Zooz one the previous year. It decided it was overloaded with just the tree leds and an led star. They replaced it with a heavier duty model. The Neocam one worked flawlessly though.

Hi @chris I have simialr problem with Neo Coolcam power plug and need help/advice (I’m not sure if new thread is needed). The 2 devices I have are not recognized in OH 3.2

I was looking in DB and found this device.

NAS-WR01ZE Wall Plug Switch - OpenSmartHouse Z-Wave Device Database

With type
Type 0003:0087,0003:1087,0003:1483,0003:2087,0020:0707

When I’m adding my device to controller I see ID like this one - 041A:0200:0008:2.23
Details inside:

zwave_version - 2.23
zwave_manufacturer - 1050
zwave_devicetype - 512
zwave_deviceid - 8

My other device that is looking exactly same but bought 2years earlier has this params - matching the 397 db reference:

zwave_version - 3.94
zwave_manufacturer - 600
zwave_devicetype - 3
zwave_deviceid - 4231

Is there a way to modify (something) locally and check if it will work or do I need to do something else / wait for the next z-wave binding release?


Please add your new device to the Z-Wave database:

Request review, wait for approval, install new Z-Wave Binding snapshot.

In theory you should be able to modify the XML file generated for this device to set the manufacturer / type and id to match another entry in the database. This isn’t a long term solution, but for testing it should work (for a while - the binding may update this data from the device so it may stop working at any time).

The correct solution is as written by @anon71759204 - to update the database to add the new device.

@chris /@anon71759204 do I need to have some special privs to create new device? The create button is not available.

To use the database you must first register on the site, then email, or open a ticket to have your access updated to allow you to edit the information. Please avoid adding comments to this page or other pages to request access or discuss issues. The comments section is to help provide a record of changes, or device issues and shouldn’t be used as a forum as it is not read routinely.

1 Like

Sory to dig out such old topic - I’m trying to fix my old devices that were sitting there doing nothing - I think even though they are plugged in - they are not expanding my z-wave network.

I’m on OH 3.4 and I tried to adjust xml “dummy” device with the one that is currently working. I have put the changed XML in /var/lib/openhab/zwave. I deleted thing and added it again.

I see it properly discovered but the values are not updated - so either it’s a different devide or figuring out the XML is way more complicated compared to what I’m trying to do.

Obviously, I’m doing something wrong but I can’t figure out what.

So I went to the Z-Wave Device Database Guide - it states " then email, or open a ticket to have your access updated"

When it comes to ticket path. Where the ticket should be placed? I got lost here a bit as I don’t know the backbones of the DB. I found OpenSmartHouse · GitHub but nothing there states about DB itself.

I sent email using form as I couldn’t find the mail anywhere.

I really would like to do as much as possible myself but it’s my first time and I feel lost a bit.

Log in to the DB. Use the dropdown up by your name to open a ticket.

1 Like