Static Image URL not displaying in Android OpenHAB app (HABPanel)

I am using the image widget to a static URL that streams using motioneye (to 192.168.x.x:8081, although I could choose any port )

Works fines when using HABPanel on edge and chrome with 200ms updates, however when using openHAB App (Android v2.13.0), I just get the image icon. Slowing the refresh rate didn’t help.

It’s not 100% clear to me if the ipcamera binding is required to solve the problem, or if this is problem with Android.

Does anyone know if this is a know problem with the image widget, and I have to add another binding?

(using OpenHAB v2.5)

It’s not very clear if your problem is with HABpanel, or the app (that uses sitemaps)

Thanks for the reply rossko57.

The issue is in HABPanel on android app (ok in browser HABPanel). Sitemap works fine.

And unfortunately beta 2.13.21 didn’t fix my problem.

Hmm, I’m trying to do the same thing, I have motioneye at the gate camera conected over RSTP to motioneye. How did you setup motioneye to serve a static image that can be get over http with the image widget? Is that a motioneye funcionality (that I cant find) or did you setup some interim webserver to serve that file.

In motion eye, set up video streaming.

In openhab sitemap

sitemap surveillance label="Surveillance" 
		Frame label="Monitors" {
		Video	label="Turret" url="" encoding="mjpeg"

In HabPanel I used a image widget with
Image Source: Static image URL
URL: is the address of the motioneye server.

But as indicated, although the HABPanel shows the stream correctly using Chrome or Edge on the PC, using the Android App, the images only work under sitemaps, and not under HABPanel.

The image widget is only for static jpg images. If you want to display mjpeg streams Like you appear to be doing, look at the camera widgets in the gallery to add to habpanel. Giving a mjpeg stream to the image widget will not work.
In your Last photo of Motion eye down the very bottom are some blue links? Put your mouse over it, The snapshot one should Work with the image widget.

If you setup streaming, there is over there an option for a snapshot url that does a job for me, That is a latest frame as jpg.

I can make a OH send it as the attachment to the telegram notification, and it should display just fine in the Habpanel on android. Will test it soon.
In my case that is not on the streaming port 8081 but at this address

Thanks for this camera widget information. Like the image widget, the camera widget works - but only HABPanel in Chrome or Edge. Neither widget (image or camera ) works in the HABPanel under Andoid App for me. (LG V30+)

It does seem to work for me, but only on Android through a browser to HABPanel, or sitemap under the App. HABPanel in the App doesn’t work.

Whilst I understand HABPanel via a browser is running on a different system to HABPanel in the android app, the fact that I can see the stream through the browser version of HABPanel on my mobile device, but not using the Android App leads me to think there is something not quite right the the app - or fundamentally working differently.

Tried this and same issues of not displaying using HABPanel in the android app. :frowning:

Then I am happy to try it to see if I can confirm the behaviour as it should work with jpg. The habpanel widget I gave the link to uses the exact same Image widget For the jpg format so they will both behave the same, however it also gives you mjpeg which may be a better match for what your trying to do with 200ms updates.

EDIT: @ray it works for me with the widget and mjpeg streams in android app then opening habapanel.

Thanks for testing. There must be something odd with my implementation - maybe it’s how I am streaming from MotionEye that gets HABPanel in the android app confused. I might put this on the back burner for a little while.

Just wondering why u want to do it via the app? There are two apps that are designed for a tablet. Habpanel viewer app the name says it all, search forum if I don’t know about it.

My guess is it is a browser issue and upgrading all packages on the tablet may fix it.

And I have just tested that HabPanelViewer (that is super cool BTW if your tablet will run it, needs android 7 at least ) does very well the motion eye snapshot url. used image URL with 2 sec refresh (I just need to see if there is a car in front of gate) Everything works as expected with images refreshing without tearing or so.

And an you do not have to enable streaming in MotionEye. Despite the fact the URL for a snaphot is in that section of the settings it still works even if the streaming is disabled

Thanks for the updates everyone

I am not using the app on a tablet, it’s running on a VG30+ phone. I’ve been using sitemaps happily before, but HABPanel is a little friendlier to lay out controls etc. All updates are current on the phone.

Sad to say, there must be something unusual about how I am running the app on my phone. HABPanel Viewer has the same problem as the OpenHab app.

I have history with 5 generation of sibo android tablets running everything from the Android 4.2 till 7 and most of the display problems (no dynamic elements, ccs not working, habpanelviewer not working at all) were related to the mobile chrome version and in the later versions of android to the webview component. Having those in the latest version is quite critical.

I run into the same Problem. Picture Displays in habpanel Browser but not in habpanel within the Android app.
Did you find the root hause or even better a resolution for this issue
I use a Samsung Galaxy Tab 3

Edit: I find it strange, that the very same picture is actually shown correctly via the a sitemap displayed with the android app. But the habpanel view does not work.