WallMote Quad (ZW130) sliding does not work

Tags: #<Tag:0x00007f4348759878>

Fair enough, if you followed my post and your device is setup as per the screenshot I’m not really sure sorry.

I have exactly the same problem. When I slide there is nothing in the logs. As if no movement is registered by openhab.

The symptoms may be the same but the problem may be different. Please open a new thread to keep troubleshooting from getting muddled.

Ok I can open a new thread but I found this in the aeotec manual:

The WallMote Quad also supports sliding control, when the parameter 4 [1 byte] has been set to 3, you can slide up or down on the button area to control a dimmer device by sliding up or down. Swiping up once will dim up a dimmer device by a certain percentage, while swiping down once will dim down a dimmer device by a certain percentage.

However in the openhab xml this is set on parameter 3 and allowable values are 0 and 1. Could this be the reason?

The symptoms may be the same but the problem may be different. Please open a new thread to keep troubleshooting from getting muddled.

With all due respect, but I disagree.

First of all: AFAIK no troubleshooting was going on anymore on the original question. At least that is the impression I get - and I was somewhat disappointed by that… From my side, this device is still sitting on my desk, I have not installed it because of this.

So, if today somebody else chimes in on this topic, and confirms to see the same, then I don’t feel this is hijacking the thread. Instead, maybe it will give the thread some new attention - or perhaps we could debug it together, exchange experiences.

To be honest, I don’t see how having 2 different threads for the same problem is favorable. Isn’t the intention of the forum to work together if you have the same problem? (or: a problem with the same symptoms?)

1 Like

What version are you running?
I see that device was last updated in March so you should likely try the install script to install a 2.5.2 snapshot version of the binding.

Zigbee and Z-Wave manual install script - Tutorials & Examples - openHAB Community

Thanks for this info. I am currently using

openHAB 2.5.1-2 (Release Build)

I am trying to find if that release is before or after march…

@Yiannis550 in habmin, the “configuration parameters” matches what is listed on the manual, here:

The page shows:

Blockquote
Button slide function
This will enable or disable the function of button slide.
Parameter 3 [1 byte]
0: Disable
1: Enable //Default Setting

I know that if you change this setting into 0, then you no longer get the “beep” (on the button itself) when sliding.

As for parameter 4, it shows:

WallMote Reports
This will allow you to configure what reports are sent when pressing WallMote Quads buttons.
Parameter 4 [1 byte]
1: Send Central Scene Command notification //Default Setting
3: Send Central Scene Command notification and Configuration Report.

Does your manual show something different?

January 12

It’s strange but in the manual online it says that parameter 3 is for slide but further down it says its parameter 4. Nor sure which is correct. I opened a ticket with aeotec support

Check it out

1 Like

Let us know what you find. I had a similar issue with another vendor but I caught it as I was entering the device. They gave me the correct answer which we then used.

Ok, thanks. In that case I should not need to install 2.5.2 snapshot to fix this.

Oh, wow - I missed that, good find!

1 Like

@Yiannis550, I plugged in my Aeotec USB stick in my PC and inspected the messages it sees from the WallMote Quad with the Zensys tool. When swiping, it is indeed sending “CONFIGURATION_REPORT” messages:

This is what I see appear when I swipe button 1 up:

08:03:44.582: Received: 042 - COMMAND_CLASS_CONFIGURATION.CONFIGURATION_REPORT, data: 09 04 01 01 7C B5
08:03:44.854: Received: 042 - COMMAND_CLASS_CONFIGURATION.CONFIGURATION_REPORT, data: 0A 04 01 01 9B B6

This is what I see when I swipe button 1 down:

08:03:47.700: Received: 042 - COMMAND_CLASS_CONFIGURATION.CONFIGURATION_REPORT, data: 09 04 01 00 B8 B7
08:03:47.813: Received: 042 - COMMAND_CLASS_CONFIGURATION.CONFIGURATION_REPORT, data: 0A 04 01 00 8C B8

Swipe Button 2 up:

08:04:54.421: Received: 042 - COMMAND_CLASS_CONFIGURATION.CONFIGURATION_REPORT, data: 09 04 02 01 9A BB
08:04:54.531: Received: 042 - COMMAND_CLASS_CONFIGURATION.CONFIGURATION_REPORT, data: 0A 04 02 01 C3 BC

Slide Button 2 down:

08:05:02.616: Received: 042 - COMMAND_CLASS_CONFIGURATION.CONFIGURATION_REPORT, data: 09 04 02 00 B0 BD
08:05:02.859: Received: 042 - COMMAND_CLASS_CONFIGURATION.CONFIGURATION_REPORT, data: 0A 04 02 00 6C BE

I think I recognize this pattern:

09/0A 04 __/__ __/__ xx xx = start slide, stop slide
__/__ 04 01/02 __/__ xx xx = button 1, button 2
__/__ 04 __/__ 01/00 xx xx = direction up, down

(and 042 happens to be the ZWave device ID)

So, the button is sending these ‘slide’ updates through ‘COMMAND_CLASS_CONFIGURATION.CONFIGURATION_REPORT’

In contrary, button presses are send through ‘COMMAND_CLASS_MULTI_CHANNEL.MULTI_CHANNEL_CMD_ENCAP’, as you can see here:

08:02:34.042: Received: 042 - COMMAND_CLASS_MULTI_CHANNEL.MULTI_CHANNEL_CMD_ENCAP, data: 00 01 5B 03 FA 00 01
08:02:35.000: Received: 042 - COMMAND_CLASS_MULTI_CHANNEL.MULTI_CHANNEL_CMD_ENCAP, data: 00 01 5B 03 FB 00 02
08:02:36.886: Received: 042 - COMMAND_CLASS_MULTI_CHANNEL.MULTI_CHANNEL_CMD_ENCAP, data: 00 01 5B 03 FC 00 03
08:02:37.905: Received: 042 - COMMAND_CLASS_MULTI_CHANNEL.MULTI_CHANNEL_CMD_ENCAP, data: 00 01 5B 03 FD 00 04

This is short-pressing button 1, then 2, then 3 then 4.

… and, to make a long story short: it does confirm that the buttons are indeed sending these messages to the controller. Openhab (or the binding) does not see them or does not know how the read these messages…

1 Like

I have tried this already. Also if you check at the beginning of this post, Johan also tried it. It does not work. I wonder if a previous build was ok and then somehow broke in the latest builds. I have binding 2.5.2 as of yesterday… Or perhaps was an AEOTEC firmware upgrade…
Anyway this code seems to expect from item BedRoom1_AeoButton_Slide2.state to have a change INCREASE or DECREASE. But in the logs I see nothing when sliding.

Indeed, same thing for me: I already tried that, it does not work.

I have 6 x WallMote Quads and the only non-default settings that I needed to change for sliding events was “Button 1/2/3/4 Multilevel”. These should be set to “Controller”, as was mentioned earlier.

The “Notification Report” settings does not need to change from its default, “Central scene”.

Because these are battery-based devices, it can take a few attempts to get the configuration to store. I found it useful to toggle the “Touch Sound” setting to be certain the revised configuration was stored.

The channel for swipe events adopts the form zwave:device:abcdef:node123:switch_startstop1.

2 Likes

Have you had any success with resolving this problem. I have just unboxed my Wallmote and I have set up all channels to relevant Items. Unfortunately, the only item receiving updates is the central scene_number all the rest hold a value of NULL.

I have been trying to force an update of the device and use the haptic setting to confirm. I can successfully switch on and off the haptic but no luck with receiving updates from channels.

@JamesB
Is it working now?

@Ben
What kind of firmware do your devices have? I have 2.3 and it is not working for me.
I am waking up the device through the action button (3 sec pres multiple time) and I have reinitialized the device so I am confident the has the correct configuration.


items

Number	WallMote_Scene			        { channel = "zwave:device:controller:node48:scene_number",       autoupdate="false"}
Number	WallMote_Scene			        { channel = "zwave:device:controller:node48:scene_number",       autoupdate="false"}

Number	WallMote_Batterie			    { channel = "zwave:device:controller:node48:battery-level",       autoupdate="false"}

String	WallMote_Swipe1		            { channel = "zwave:device:controller:node48:switch_startstop1",       autoupdate="false"}
String	WallMote_Swipe2		            { channel = "zwave:device:controller:node48:switch_startstop2",       autoupdate="false"}
String	WallMote_Swipe3		            { channel = "zwave:device:controller:node48:switch_startstop3",       autoupdate="false"}
String	WallMote_Swipe4		            { channel = "zwave:device:controller:node48:switch_startstop4",       autoupdate="false"}

Number	WallMote_Scene1			        { channel = "zwave:device:controller:node48:scene_number1",       autoupdate="false"}
Number	WallMote_Scene2			        { channel = "zwave:device:controller:node48:scene_number2",       autoupdate="false"}
Number	WallMote_Scene3			        { channel = "zwave:device:controller:node48:scene_number3",       autoupdate="false"}
Number	WallMote_Scene4			        { channel = "zwave:device:controller:node48:scene_number4",       autoupdate="false"}

linked:

[.ItemChannelLinkAddedEvent] - Link 'WallMote_Scene-zwave:device:controller:node48:scene_number' has been added.
[.ItemChannelLinkAddedEvent] - Link 'WallMote_Batterie-zwave:device:controller:node48:battery-level' has been added.
[.ItemChannelLinkAddedEvent] - Link 'WallMote_Swipe1-zwave:device:controller:node48:switch_startstop1' has been added.
[.ItemChannelLinkAddedEvent] - Link 'WallMote_Swipe2-zwave:device:controller:node48:switch_startstop2' has been added.
[.ItemChannelLinkAddedEvent] - Link 'WallMote_Swipe3-zwave:device:controller:node48:switch_startstop3' has been added.
[.ItemChannelLinkAddedEvent] - Link 'WallMote_Swipe4-zwave:device:controller:node48:switch_startstop4' has been added.
[.ItemChannelLinkAddedEvent] - Link 'WallMote_Scene1-zwave:device:controller:node48:scene_number1' has been added.
[.ItemChannelLinkAddedEvent] - Link 'WallMote_Scene2-zwave:device:controller:node48:scene_number2' has been added.
[.ItemChannelLinkAddedEvent] - Link 'WallMote_Scene3-zwave:device:controller:node48:scene_number3' has been added.
[.ItemChannelLinkAddedEvent] - Link 'WallMote_Scene4-zwave:device:controller:node48:scene_number4' has been added.

Configuration

Association groups

Edit:
If I slide I can observe the following parts in the log

23-Okt-2020 16:19:05.431 [DEBUG] [ng.zwave.internal.protocol.ZWaveTransactionManager] - NODE 48: Checking command org.openhab.binding.zwave.internal.protocol.ZWaveCommandClassPayload@99f90b.
23-Okt-2020 16:19:09.516 [DEBUG] [ng.zwave.internal.protocol.ZWaveTransactionManager] - NODE 48: Application Command Request (ALIVE:DONE)
23-Okt-2020 16:19:09.518 [DEBUG] [.openhab.binding.zwave.internal.protocol.ZWaveNode] - NODE 48: resetResendCount initComplete=true isDead=false
23-Okt-2020 16:19:09.519 [DEBUG] [.openhab.binding.zwave.internal.protocol.ZWaveNode] - NODE 48: Incoming command class COMMAND_CLASS_SWITCH_MULTILEVEL, endpoint 0
23-Okt-2020 16:19:09.520 [DEBUG] [.openhab.binding.zwave.internal.protocol.ZWaveNode] - NODE 48: SECURITY not supported
23-Okt-2020 16:19:09.520 [DEBUG] [e.internal.protocol.commandclass.ZWaveCommandClass] - NODE 48: Received COMMAND_CLASS_SWITCH_MULTILEVEL V3 SWITCH_MULTILEVEL_START_LEVEL_CHANGE
23-Okt-2020 16:19:09.521 [DEBUG] [col.commandclass.ZWaveMultiLevelSwitchCommandClass] - NODE 48: Switch Multi Level start level change, direction = DECREASE
23-Okt-2020 16:19:09.522 [DEBUG] [rg.openhab.binding.zwave.handler.ZWaveThingHandler] - NODE 48: Got an event from Z-Wave network: ZWaveStartStopEvent
23-Okt-2020 16:19:09.523 [DEBUG] [rg.openhab.binding.zwave.handler.ZWaveThingHandler] - NODE 48: Got a value event from Z-Wave network, endpoint=0, command class=COMMAND_CLASS_SWITCH_MULTILEVEL, value=DECREASE
23-Okt-2020 16:19:09.525 [DEBUG] [ng.zwave.internal.protocol.ZWaveTransactionManager] - NODE 48: Commands processed 1.
23-Okt-2020 16:19:09.526 [DEBUG] [ng.zwave.internal.protocol.ZWaveTransactionManager] - NODE 48: Checking command org.openhab.binding.zwave.internal.protocol.ZWaveCommandClassPayload@191557f.
23-Okt-2020 16:19:09.530 [DEBUG] [ng.zwave.internal.protocol.ZWaveTransactionManager] - NODE 48: Application Command Request (ALIVE:DONE)
23-Okt-2020 16:19:09.530 [DEBUG] [.openhab.binding.zwave.internal.protocol.ZWaveNode] - NODE 48: resetResendCount initComplete=true isDead=false
23-Okt-2020 16:19:09.531 [DEBUG] [.openhab.binding.zwave.internal.protocol.ZWaveNode] - NODE 48: Incoming command class COMMAND_CLASS_SWITCH_MULTILEVEL, endpoint 0
23-Okt-2020 16:19:09.532 [DEBUG] [.openhab.binding.zwave.internal.protocol.ZWaveNode] - NODE 48: SECURITY not supported
23-Okt-2020 16:19:09.533 [DEBUG] [e.internal.protocol.commandclass.ZWaveCommandClass] - NODE 48: Received COMMAND_CLASS_SWITCH_MULTILEVEL V3 SWITCH_MULTILEVEL_STOP_LEVEL_CHANGE
23-Okt-2020 16:19:09.534 [DEBUG] [col.commandclass.ZWaveMultiLevelSwitchCommandClass] - NODE 48: Switch Multi Level stop level change
23-Okt-2020 16:19:09.535 [DEBUG] [rg.openhab.binding.zwave.handler.ZWaveThingHandler] - NODE 48: Got an event from Z-Wave network: ZWaveStartStopEvent
23-Okt-2020 16:19:09.536 [DEBUG] [rg.openhab.binding.zwave.handler.ZWaveThingHandler] - NODE 48: Got a value event from Z-Wave network, endpoint=0, command class=COMMAND_CLASS_SWITCH_MULTILEVEL, value=STOP
23-Okt-2020 16:19:09.537 [DEBUG] [ng.zwave.internal.protocol.ZWaveTransactionManager] - NODE 48: Commands processed 1.
23-Okt-2020 16:19:09.538 [DEBUG] [ng.zwave.internal.protocol.ZWaveTransactionManager] - NODE 48: Checking command org.openhab.binding.zwave.internal.protocol.ZWaveCommandClassPayload@92f27b.