ZWave Dual Paddle displays as Single

  • Platform information:

    • Hardware: PPI2
    • OS: openhabian
    • Java Runtime ?
    • openHAB version:2.3.0
  • Issue of the topic:
    I have a simple setup with an Aeontech ZStick Gen 5 and TKB TZ55B Dual Paddle Light Switch / Dimmer. I have sucessfully included the light switch with the stick but it shows up in openhab as a TZ35s (a single paddle switch). Therefore, there are no assoiation groups for the second paddle displayed.

Where can I start looking to get this switch correctly reported in OpenHab?

  • Please post configurations (if applicable):
    • Items configuration related to the issue
    • Sitemap configuration related to the issue
    • Rules code related to the issue
    • Services configuration related to the issue
  • If logs where generated please post these here using code fences:

Upgrade to the latest 2.4 snapshot zwave binding. When I remember correctly there have been a lot of database updates to those devices. With upgrading to the latest snapshot you will be able to get those changes.

Make sure you perform all steps in this post, upgrade has breaking changes:

OK, thanks

I updated to 2.4.x snapshot, removed things, removed binding, restored binding and re-added zwave devices.

Still showing as the wrong product (single paddle when it should eb a dual paddle). Anything else worth trying?


You copied the jar file to your /addons folder?

Thanks for coming back. I followed these steps from the referenced thread.

Step 5 explicitly states that JARs are not modified if never dropped into addons. This is a brand spanking new install of openhabian with no JAR tomfoolery carried out. Therefore I followed the instructions to conduct all changes through the UI.

That is for snapshot releases, you are on stable.
Download the jar and drop it into your addons folder.
Uninstall the stable zwave binding first.

Well it looks like I’m on snapshot, not stable anymore.

I removed the zwave binding, dropped the JAR into /usr/share/openhab2/addons and restarted the system but still the same issue.

Is that the correct addons folder, it was empty?

I’m finding the steps quite fragmented for this process :frowning:

Now it is a different story :grinning:
As you already found out in your above post in a snapshot release you can install the snapshot zwave binding just by hitting the install button in a GUI.

From this back and forth I would suggest to check via karaf and bundle:list | grep ZWave that only the recent snapshot binding is active.

Only if you want to use newer snapshot bindings with old stable releases :sunglasses:

If nothing helps check your corresponding xml file in /userdata/zwave folder and compare manufacturer, thing and device type to the database.

OK, thanks @sihui
I get about 50% of that so lets see what happens…

So I found the correct device in the database;

Don’t know what to do next?

Looks like that is the case;


You’ll need to delete the jar file in the addons directory. Having two zwave bindings installed will cause issues.

Thanks for taking the time to respond.

You mean I need to delete the jar file It was suggested I add earlier? So no Jar file required.

It’s pretty easy: in your first post you told us you are on 2.3 stable. So I told you how to get the latest database definitions (add 2.4 binding jar). In some later post you were magically on 2.4 snapshot. Now I told you how to get the database updates if on that version (remove the jar and just install zwave through GUI).

Now you have two zwave bindings on your system, so remove one. You may need to clean the tmp and cache folder and restart openHAB again …

Nothing magical about it. I was on stock 2.3. I followed the detailed instructions for updating the binding (linked earlier) which include the line;

  1. If you are not already running 2.4 snapshots, then upgrade OH using the procedure for your platform.

That’s where the magic happened!

Anyway, I really do appreciate all the pointers. I have removed the JAR file and cleared tmp and cache directories as instructed. I now have a single zwave binding listed in Karaf.

Still no joy though, the Dual Paddle stubbornly reports as a single.

Have you compared the xml to the database? The binding generates the xml with info from the device, and uses it to identify it in the db. Please post your xml.

Yes I have. Earlier, I linked to what is the correct item in the database for my device;

My problem is, that’s not what’s being loaded for me in OpenHab. Instead, I have this;

node5.xml (5.7 KB)


If this is what your device is reporting, then it will never match up to this device in the db…

References (Type:Id)	0003:0004,0311:0201

… but it will be recognized as this…

If the device has two paddles, then this seems like a device issue… the binding is doing everything it’s supposed to do. Maybe it was loaded with the wrong firmware? Or the firware has changed and the type:id changed too. You sure it has two paddles :slight_smile:?

Yes. Visual inspection confirms. No firmware updates on the device. And it’s reported correctly in Home Assistant, just that platform cant access the second paddle (known issue).