Can't connect IRIS Garage Door Controller to openHABianpi

Hi I’m new and picking this up as fast as I can.

I just got my Raspberry Pi 3 running with openHABian and can access it through putty. And I added a Aeotec Z-Stick Gen5, Z-Wave Plus USB stick.

I went to openhabianpi:8080 on my browser and went to paper and added the z-wave binding, installed the binding.

Went to inbox and z-wave binding add serial port /dev/ttyACMO

All as per yoyoTech’s video:

I have installed the garage door opener:
and hooked it up

Went to z-wave bindings and searched and nothing comes up.

What am I doing wrong here?


Did you put your zwave in inclusion mode? I use Habmin to do this…

No, what is HABmin?

Edit: I did some searching and came up with this:

I’ve run out of time for today but may get back to it tonight or tomorrow night.

Any help or advice would be great! LOL


In order for your OH to see your Zwave devices, you need to include (“pair”) your Zwave device to your network. This is called inclusion, since you’re basically including your device to your zwave network. First, you need the HUB to be inclusion mode so that the devices trying to “join” will be included. If you have the zwave usb stick (AeonLabs?) you can simply click the button, or, through Habmin, you can put your zave hub/controller by using this:

I’m on OH2 (I think). I just downloaded and installed this week openHABianpi. Does my install even have HABmin? I don’t see it on the openhabpi:8080 opening page. Where can I find HABmin?

Here’s a screenshot:

for your help Lucky!

Click on Paper UI, then select Addons

At the top find user interfaces and click, scroll down the list and click the Install button on the line with HabMin

Thanks KidSquid,
So I have the NGDOOZ-4 Garage door Controller along with the Z-Wave serial Controller displayed in things under configuration.

I don’t know if it matters but my device is the GD00Z-1 not the NGD00Z-4 as displayed in openHAB.

If I click on this device under show properties all I see is “Barrier State”

But if I click on Control (above Inbox) there is nothing there.

So, am I possible missing some software from Z-wave or the GD00z-1 (Iris) manufacturer?
Or what else am I missing?

Thanks again

I’m at a loss here. Is it possible to get this thing (IRIS Garage Door Controller - Linear GD00Z-1 ) running? Maybe I have bit off more than I can chew. I do have some Linux terminal experience if I need to go in and add/edit files.

Maybe I should look for another solution. Something like this:
Less than 2 Hours + Less than $200.00 = 2 Garage Doors and 1 Gate Automated + plus one very happy family who can use Alexa to operate

Or as Rikoshak says here:

But the opener I bought was $85 and it would be another $100 for the Contact Fixture Module and Garage Door Tilt Sensor. I doubt Amazon will take the Iris back.

Huh, what to do?

Is there some place that I can start reading? I have found some threads where “Chris Jackson - Maintainer” has had some discussions about getting this device running but I can’t seem to gather if there was ever a solution.

Linear GD00Z Garage Door Opener Will Not Operate

Issues Secure Pairing GoControl/Linear GD00Z-4 Garage Door Opener

OpenHab2 and Linear NGD00Z-4 Garage Door Controller - zwave


I don’t know the device. It looks like it might be miss identified, in which case the zwave db needs to be fixed. @chris, does that seem right?


I’m curious why some users see my username as rikoshak instead of rikoshak. It doesn’t really bother me, I’m just curious. It seems to happen work some frequency.

True story. When the forum moved off of Google Groups there was a mixup and I missed my chance to choose my own username. Well, I could have changed it but I would have lost everything I had posted up to that point (around 100 posts) so I’ve stuck with this handle. I would have chosen paperrhino (origami is one of my hobbies).

I doubt it’s mis-identified - it seems that the device is likely to be right and the channels are identified ok. The name on the box is not necessarily the same as the name on the inside.

One thing I do note is that this device should have 2 channels, so I could guess that you’re running an old version of the binding? If so, I’d recommend running the latest snapshot - just so we know where we are.

I’m not familiar with the device - I think @5iver has one so might be able to comment on how to get it going.

Ummm - isn’t this the same? I think you’ve got your own username wrong now and I assume one of these two is meant to be rlkoshak? :wink: Maybe you’ve answered you’re own question :sunglasses:


Well as the author of that tutorial I can tell you it was extremely easy and it’s what led me to continue to use OH and further my knowledge of the system.

I think reaching out to @5iver as Chris suggested is a good next step. If you still can’t get the device working, Amazon has a fairly liberal return/exchange program. If you reach out to their customer service folks and let them know you want to exchange for another product, they may be a bit forgiving on time.

Let me know if I can help out.


I read though this thread, but I didn’t see anyone mention this yet. Since this device uses the SECURITY Command Class, which is not included in the 2.2 release version of the binding, you will need the development version of the binding…

You’ll need to uninstall the 2.2 version first, then drop the jar from the first post into your addons folder. Or you can install it though Eclipse Marketplace. The opener will need to be excluded, and then I usually do a reset (5 presses of the button, and it will give you a few short beeps and then a long shrieky one). Then reincluded the device using OH (not the button on the stick) from close proximity to the controller. It sounds like you are familiar with the inclusion process, since you got it done the first time. You’ll also need to delete all of your Things and rediscover to pull in the updated ThingTypes. Not excluded/reinclude… just delete the Thing.

And FYI, I recently added the second channel, alarm_raw to test it out. There are only a very few occasions when this would get a value. I haven’t gotten it to report anything yet, but haven’t put much time into it. From Zwave Command Class Specification… Error Handling

The device MUST stop if any safety issue is detected.

If the requested operation is overruled by a safety mechanism, the device MUST notify the requester via
a Notification Report (Notification Type: “Access Control”, Event: “Barrier unable to perform requested
operation due to safety requirements”). The Notification Report command is a member of the Notification
Command Class.

Thanks so much everybody.

So following Scott’s instructions:

  1. I went to Paper UI / Add-ons / Bindings and uninstalled z-wave.
  2. Then I wget’ed the March 4th 2018 .JAR file into:
    /srv/openhab2-sys/addons. - (I didn’t unpack it or anything. I just placed the .JAR file there.)
  3. Where do I exclude the opener?
  4. I’ll go unscrew the thing from the garage ceiling (no problem) so I can get the device next to the R Pi but the last time I couldn’t figure out how to include the device through the openHAB UI. I ended up using the button on the USB dongle. Can you tell me where I can do that?

I think that will keep me for now.

Thanks all of you guys for walking me through this thing.


You could do this through PaperUI, but for many reasons, get used to Habmin. Select Configuration> Things> your controller> Tools (over on the top right)> Advanced Options> Exclude

There’s a magnifying glass with a plus sign in it between the hamburger and plus signs. Select that and then the zwave binding. You can’t secure include through the dongle itself.

Hopefully that will get you to the finish line!

It seems that I am having trouble uninstalling the z-wave binding. I thought I did it the last time but after failing to get the garage opener to work I checked through and see the binding is still version 2.2. The new one is version 2.3 (I think).
So I remember when I went to Paper UI / Add-ons / Bindings and uninstalled z-wave it just kept cycling and never showed completion. So I tried it again and it is still cycling.

So I went to HABmin / configuration / things and removed both the z-wave and the 2 instances of the garage door opener that were there and went back to Paper UI / Add-ons / Bindings again and tried to uninstall again and it doesn’t work.

Do I have to remove the z-wave USB dongle first or something?
Any ideas?


Is the zwave binding in your /conf/services/addons.config? If so, remove it from the file. If that isn’t it, and PaperUI isn’t uninstalling it properly (there should be logs), then you could try feature:uninstall org.openhab.binding.zwave in your Karaf console.

OK, I did a re-install of openHABianpi so I could start from scratch. Under ParerUI / Configuration / Things I have Node 2 (Unknown device), Node 3 NGD00Z-4 Garage door Opener and the Z-Wave serial controller.

I think the next step is to go to control and see the device listed but when I go there, there is nothing there.

What did I d? Well,. after doing a clean install of the OS I added the new bindings file into the addons directory. Then I fumbled around through the UI, the Linux terminal and the Karaf console all day until I have gotten to this point again.

I didn’t add the new Z-Wave Devices through the HABmin UI. It really didn’t give me a chance. I guess I could go and delete the devices and reset the Garage Door Opener with 5 presses of the button.and try to re-discover the stuff but do I need to.

I just don’t see the door opener in the paperui / control panel and I think that I should.

Am I doing this wrong?

Here are some screen grabs going in reverse chronological order:

Are you still getting the singleton=true error messages, or did you finally get just the one zwave binding running? From the fresh install, did you install the zwave binding through PaperUI, or add it to addons.cfg? I’m not sure how else it could be getting installed.

The zwave devices are stored in the controller itself. When the binding starts up, it queries the controller to get the list of devices that it has on the network. From the screenshots, you’re devices were still initializing, but you had two bindings running. There really was not need to reinstall everything. Once you have the one binding running, if you have not yet excluded the garage opener, you will need to in order to reinclude it securely. You can exclude with the zstick or through OH (select the controller in Habmin> Tools> Show Advanced Settings> Exclude Devices. Then delete the old Thing. You will need to take the garage opener down to do the inclusion, or move the Pi to the garage.

[quote=“5iver, post:19, topic:41043”]
Are you still getting the singleton=true error messages, or did you finally get just the one zwave binding running? [/quote]

I’m not sure what the “singleton=true” message is but looking at the PaperUI > Configuration > Bindings I see just one instance of ZWave. And in Paperui > Configuration > Things I see one ZWave serial controller and two nodes for the garage door (one unknown).

But if I go to Paper UI > Addons > Bindings I see that the ZWave binding is installed but it still says version 2.2.0. Although if i look in the Karaf console command bundle:list | gerp ZWave I see that 2.2.0 states installed but only version 2.3.0 states Active. So that’s good right?

[quote=“5iver, post:19, topic:41043”]
From the fresh install, did you install the zwave binding through PaperUI, or add it to addons.cfg? I’m not sure how else it could be getting installed.[/quote]

The last time I did a search in the Linux directories for addons and found:


so I put the 2.3.0 binding snapshot there. This time I put it in:


and it seem to have propagated to:


After I added the 2.3.0 snapshot to the directory I went to the ParerUI > Addons > Bindings and saw the listed binding was stated to still be 2.2.0. I did some searching through the “OH2 Z-Wave refactoring and testing… and SECURITY” thread and found some strange commands like:

feature:install openhab-transport-serial

and a few others and ran them from the Karaf console. When I went back to the PaperUI > Addons > Bindings Console it still read the ZWave binding as 2.2.0 but I installed it through this PaperUI Binding anyways (at this point I had tried everything I could through at it to change it and didn’t care anymore.)

But in the bundle: list readout it only shows 2.3.0 as active. So I’m goo right?

I’ve gotta go for now but if I have time tonight I’ll try to uninstall the garage opener and reinstall it securely through HABmin. The device is still setting on the floor next to my Raspberry Pi until I get this worked out.

Thanks so much for sticking with me through all of this. I think I’m getting close and I’m not having a bad time playing and learning the karaf console. I really needed to brush up on my Linux terminal anyways. LOL

Here are some screen grabs from today: