openHAB 3.0 Release discussion

@J-N-K After upgrading to OH3, I get a WARN from a HTTP Thing. Nothing changed in the configuration, this worked in OH2, with the HTTP2 binding (of course it was an older version, but I can’t say for sure which one was that).

Requesting '' (method='GET', content='null') failed: 403 rate limit exceeded

I would interpret this as too many requests in short time.

Yes this seems like so, but I have not changed anything in the config and in OH2, the same refresh rate did not caused this. I will try to increase the refresh rate.

Java didn’t got installed. (was still on 8)
check in terminal: java -version
you need java 11, if its not installed, its in openhabian config = Menu 46

A post was split to a new topic: Upgrade issues

Is there any issue with semantic classes and the registration at Google Assistant via I described the issue here: OH3 MainUI: How to register (and exclude) items for Google Assistant and Amazon Alexa?. In short, any Tradfri light included via MainUI with semantic class “lightbulb” automatically seems to receive tags that register them with Google Assistant which is not desired for me.

I’ve just downloaded OH3 onto a test Raspberry and so far everything seems to be working fine. One question though, is it possible to add Things textually like it’s possible to do with Items under the “Developer options”?

I have maybe a hundred MQTT things (shellies) that are all textually defined in my current OH2.5 setup and most of them are just copy-paste with an incremented number or similar. It would be a pain (to put it lightly) to manually enter them all and then link them to equipment.

In general, is creating “equipment” in batch processes possible?

1 Like

No you cannot batch create Things (from text form) for the time being like you can do with Items.
But OH3 just works as OH2 used to so putting up your .things files will make them available in the config as it used to in OH2.

I did.
It was no issue at all.

  1. I updated Ubuntu to 20.04 LTS (before it was the former LTS version)
  2. I installed JRE 11 (Zulu) after adding the repository
  3. I installed OH3 package after adding the repository. OH3 did the migration of OH2 during this step.
  4. I purged the OH2 package
  5. I puged the JRE 8 package needed for OH2
  6. I reinstalled the OH3 package to fix the issue caused by the removal of the user openhab in step 4
  7. Rebooted

Everything was fine.

1 Like

A post was split to a new topic: Questions on OH3

A post was split to a new topic: GPStracker in OH3

hi just upgraded openhabian. is it a known issue that a modified port is ignored by the upgrade procedure? my OH2 was running on port 8000, after upgrading it falls back to 8080

Just completed upgrade to OH3. I started with a new OpenHABain build.

I use text configuration so it was an absolute breeze. Most of my 280 or so items working in under an hour.

I’m now working on porting the HTTP config to the new binding - I didn’t count that in the upgrade time because v1 bindings are always going to take time to transfer. I am missing the “copy channel name to clipboard” that used to be in PaperUI - made getting item configs right first time much easier.

InfluxDB seems fine but I also log to jdbc-mariadb as I was halfway through migrating to Influx under OH2.

All I need now is a TCP binding to control my OpenEVSE. I had the v1 one running under OH2 but it had a memory leak so I needed to reboot every couple of days. Hopefully the new version is being worked on and won’t have that problem.

Cron based rules are working at the moment but should probably migrate to Scheduler.
I need to get Google Calendar working but that wasn’t complete in OH2 so the work is the same.

Thanks so much to the developers for a great system and an easy upgrade path (using text config anyway)


The scheduler is just a way to show when your cron and other time based rules. If you add a Schedule tag to your existing cron triggered rules they will show up there.

1 Like

Thanks, I’ll have a look at that.

BTW, getting the HTTP working was pretty straightforward using some examples from the forum.

It’s great to be able to do such a major upgrade in an afternoon - leaves lots of time to start looking at the new features.

1 Like

Could you please provide an example, how I can add a Schedule tag to text based rules?
Thank you in advance

I don’t think you can with rules DSL. For the other languages, it’s one of the arguments you pass when creating the rule.

4 posts were split to a new topic: Issue with cloud and Echo

Looks like the current download page is not currently working. I could not select the platform. I used next instead and got the Windows file I wanted. Also, I could not reach the download page from the top menu. I had to use a direct link.
KR, Martin

3 posts were split to a new topic: Readonly mount