openHAB 3.3 Milestone discussion

Can someone who has the zwave issue please send her/his configuration (either the .json if UI configured or the .things file) to me (github@klug.nrw)? I just tried

Bridge zwave:serial_zstick:controller "ZWave Controller" [ port="/dev/ttyACM0", controller_softreset="false", controller_master="true", heal_enable="true", security_networkkey="XXX" ]
{
	fibaro_fgwreu111_00_000 sensor1 "Sensor 1" [ node_id=1 ]
}

and 255 passes the config validation for config_duration of the blinds_control1 channel, so something must be special in your setup.

Where can I find the .json files?

To get around the problem I have to go to the thing and press save. I do not need to change anything.

But as soon as I restart my RasberryPi4 I have to repeat this unfortunately.

On my system the location is /var/lib/openhab/jsondb/org.openhab.core.thing.Thing.json. I believe this is also true for openHABian.

You know what is weird?
I had “fixed” all values from 255 to 254 yesterday of the things that became offline and all my things went online again after applying 254.
So to be able to send you the thing-file I just put one channel config of one thing back to 255 and guess what, the thing is still online!

Let me restart openHAB and see if it is a startup issue…

So after the startup I have two nodes that are on error. I will document and save anything before I try to refix it (note that I have many zwave nodes that are all online except of the two)

Node 87:

Only ONE channel is configured

and it is set to 255

I will send you that file network_fed4ea89__node_87.xml

Node 91:

again only one channel is configured

But believe me it is on 254!!! So it is NOT greater the 254!

i will send you this file as well: network_fed4ea89__node_91.xml

I will now change both values to 1 (second) and see if they go online (change step duration and click on done - save is not needed for the thing)

and yes, both will go back to online. Btw, it says “Thing saved” in the UI.

Now the value in thing.json is on 1.0

I can confirm what Jeff is saying

If I can help you with a debug session, let me know.

ZWave-issue: Fix is on the way - Fix config validation for integer values by J-N-K · Pull Request #3010 · openhab/openhab-core · GitHub

2 Likes

After upgrading from 3.2.0 to 3.3.0.M7, none of my custom bundles/jar files in the addons folder was loaded and started automatically. They all stayed in RESOLVED status, but a bundle:start <bundleid> got them running.

Since M7 I have a strange behaviour, which did not occur in M6.

I’m reading the thing configuration via REST API and parse the JSON file for some values.
There I get this data:
2022-06-21 21:30:15.892 [ERROR] [odel.script.system.fnThingInfoWakeUp] - {"channels":[{"linkedItems":[],"uid":"zwave:device:gehirn:node36:sensor_binary","id":"sensor_binary","channelTypeUID":"zwave:sensor_binary","itemType":"Switch","kind":"STATE","label":"Binary Sensor","description":"Indicates if a sensor has triggered","defaultTags":[],"properties":{"binding:*:OnOffType":"COMMAND_CLASS_SENSOR_BINARY"},"configuration":null},{"linkedItems":["num_Bath_Luminance"],"uid":"zwave:device:gehirn:node36:sensor_luminance","id":"sensor_luminance","channelTypeUID":"zwave:sensor_luminance","itemType":"Number","kind":"STATE","label":"Sensor (luminance)","description":"Indicates the current light reading","defaultTags":[],"properties":{"binding:*:DecimalType":"COMMAND_CLASS_SENSOR_MULTILEVEL;type\u003dLUMINANCE"},"configuration":null},{"linkedItems":["num_Bath_Humidity"],"uid":"zwave:device:gehirn:node36:sensor_relhumidity","id":"sensor_relhumidity","channelTypeUID":"zwave:sensor_relhumidity","itemType":"Number","kind":"STATE","label":"Sensor (relative humidity)","description":"Indicates the current relative humidity","defaultTags":[],"properties":{"binding:*:DecimalType":"COMMAND_CLASS_SENSOR_MULTILEVEL;type\u003dRELATIVE_HUMIDITY"},"configuration":{}},{"linkedItems":["num_Bath_Temp"],"uid":"zwave:device:gehirn:node36:sensor_temperature","id":"sensor_temperature","channelTypeUID":"zwave:sensor_temperature","itemType":"Number:Temperature","kind":"STATE","label":"Sensor (temperature)","description":"Indicates the current temperature","defaultTags":[],"properties":{"binding:*:QuantityType":"COMMAND_CLASS_SENSOR_MULTILEVEL;type\u003dTEMPERATURE"},"configuration":{}},{"linkedItems":[],"uid":"zwave:device:gehirn:node36:alarm_motion","id":"alarm_motion","channelTypeUID":"zwave:alarm_motion","itemType":"Switch","kind":"STATE","label":"Motion Alarm","description":"Indicates if a motion alarm is triggered","defaultTags":[],"properties":{"binding:*:OnOffType":"COMMAND_CLASS_ALARM"},"configuration":{}},{"linkedItems":["num_Bath_Sensor_Battery"],"uid":"zwave:device:gehirn:node36:battery-level","id":"battery-level","channelTypeUID":"system:battery-level","itemType":"Number","kind":"STATE","label":"Batterieladung","defaultTags":["Measurement","Energy"],"properties":{"binding:*:PercentType":"COMMAND_CLASS_BATTERY"},"configuration":{}}],"statusInfo":{"status":"ONLINE","statusDetail":"NONE"},"editable":true,"label":"Sensor Badezimmer","bridgeUID":"zwave:serial_zstick:gehirn","configuration":{"config_10_1":10.0,"wakeup_interval":3600.0,"group_1":["controller"],"group_2":[],"config_111_2":5.0,"config_112_1":2.0,"config_100_1":1.0,"config_110_1":1.0,"config_101_4":0.0,"config_102_4":0.0,"config_113_2":150000.0,"config_114_1":1.0,"config_12_1":0.0,"config_103_4":86400.0,"config_13_2":30.0,"config_14_1":0.0,"config_104_4":0.0,"config_15_1":0.0,"node_id":36},"properties":{"zwave_class_basic":"BASIC_TYPE_ROUTING_SLAVE","zwave_class_generic":"GENERIC_TYPE_SENSOR_NOTIFICATION","zwave_lastwakeup":"2022-06-21T19:30:06Z","zwave_neighbours":"4,5,7,17,18,29,47","modelId":"SHBW10000","zwave_plus_devicetype":"NODE_TYPE_ZWAVEPLUS_NODE","zwave_version":"2.2","defaultAssociations":"1","vendor":"ABUS Security-Center GmbH \u0026 Co. KG","zwave_routing":"true","zwave_beaming":"true","zwave_secure":"false","zwave_class_specific":"SPECIFIC_TYPE_NOTIFICATION_SENSOR","zwave_devicetype":"2","zwave_frequent":"false","zwave_listening":"false","manufacturerId":"0403","manufacturerRef":"0002:0001","dbReference":"1103","zwave_deviceid":"1","zwave_nodeid":"36","zwave_lastheal":"2022-06-19T12:30:10Z","zwave_plus_roletype":"ROLE_TYPE_SLAVE_SLEEPING_REPORTING","zwave_manufacturer":"1027"},"UID":"zwave:device:gehirn:node36","thingTypeUID":"zwave:abus_shbw10000_00_000"}

Looking at the same data via the API explorer I receive this:

{
  "channels": [
    {
      "linkedItems": [],
      "uid": "zwave:device:gehirn:node36:sensor_binary",
      "id": "sensor_binary",
      "channelTypeUID": "zwave:sensor_binary",
      "itemType": "Switch",
      "kind": "STATE",
      "label": "Binary Sensor",
      "description": "Indicates if a sensor has triggered",
      "defaultTags": [],
      "properties": {
        "binding:*:OnOffType": "COMMAND_CLASS_SENSOR_BINARY"
      },
      "configuration": {}
    },
    {
      "linkedItems": [
        "num_Bath_Luminance"
      ],
      "uid": "zwave:device:gehirn:node36:sensor_luminance",
      "id": "sensor_luminance",
      "channelTypeUID": "zwave:sensor_luminance",
      "itemType": "Number",
      "kind": "STATE",
      "label": "Sensor (luminance)",
      "description": "Indicates the current light reading",
      "defaultTags": [],
      "properties": {
        "binding:*:DecimalType": "COMMAND_CLASS_SENSOR_MULTILEVEL;type=LUMINANCE"
      },
      "configuration": {}
    },
    {
      "linkedItems": [
        "num_Bath_Humidity"
      ],
      "uid": "zwave:device:gehirn:node36:sensor_relhumidity",
      "id": "sensor_relhumidity",
      "channelTypeUID": "zwave:sensor_relhumidity",
      "itemType": "Number",
      "kind": "STATE",
      "label": "Sensor (relative humidity)",
      "description": "Indicates the current relative humidity",
      "defaultTags": [],
      "properties": {
        "binding:*:DecimalType": "COMMAND_CLASS_SENSOR_MULTILEVEL;type=RELATIVE_HUMIDITY"
      },
      "configuration": {}
    },
    {
      "linkedItems": [
        "num_Bath_Temp"
      ],
      "uid": "zwave:device:gehirn:node36:sensor_temperature",
      "id": "sensor_temperature",
      "channelTypeUID": "zwave:sensor_temperature",
      "itemType": "Number:Temperature",
      "kind": "STATE",
      "label": "Sensor (temperature)",
      "description": "Indicates the current temperature",
      "defaultTags": [],
      "properties": {
        "binding:*:QuantityType": "COMMAND_CLASS_SENSOR_MULTILEVEL;type=TEMPERATURE"
      },
      "configuration": {}
    },
    {
      "linkedItems": [],
      "uid": "zwave:device:gehirn:node36:alarm_motion",
      "id": "alarm_motion",
      "channelTypeUID": "zwave:alarm_motion",
      "itemType": "Switch",
      "kind": "STATE",
      "label": "Motion Alarm",
      "description": "Indicates if a motion alarm is triggered",
      "defaultTags": [],
      "properties": {
        "binding:*:OnOffType": "COMMAND_CLASS_ALARM"
      },
      "configuration": {}
    },
    {
      "linkedItems": [
        "num_Bath_Sensor_Battery"
      ],
      "uid": "zwave:device:gehirn:node36:battery-level",
      "id": "battery-level",
      "channelTypeUID": "system:battery-level",
      "itemType": "Number",
      "kind": "STATE",
      "label": "Batterieladung",
      "defaultTags": [
        "Measurement",
        "Energy"
      ],
      "properties": {
        "binding:*:PercentType": "COMMAND_CLASS_BATTERY"
      },
      "configuration": {}
    }
  ],
  "statusInfo": {
    "status": "ONLINE",
    "statusDetail": "NONE"
  },
  "editable": true,
  "label": "Sensor Badezimmer",
  "bridgeUID": "zwave:serial_zstick:gehirn",
  "configuration": {
    "config_10_1": 10,
    "wakeup_interval": 3600,
    "group_1": [
      "controller"
    ],
    "group_2": [],
    "config_111_2": 5,
    "config_112_1": 2,
    "config_100_1": 1,
    "config_110_1": 1,
    "config_101_4": 0,
    "config_102_4": 0,
    "config_113_2": 150000,
    "config_114_1": 1,
    "config_12_1": 0,
    "config_103_4": 86400,
    "config_13_2": 30,
    "config_14_1": 0,
    "config_104_4": 0,
    "config_15_1": 0,
    "node_id": 36
  },
  "properties": {
    "zwave_class_basic": "BASIC_TYPE_ROUTING_SLAVE",
    "zwave_class_generic": "GENERIC_TYPE_SENSOR_NOTIFICATION",
    "zwave_lastwakeup": "2022-06-21T19:30:06Z",
    "zwave_neighbours": "4,5,7,17,18,29,47",
    "modelId": "SHBW10000",
    "zwave_plus_devicetype": "NODE_TYPE_ZWAVEPLUS_NODE",
    "zwave_version": "2.2",
    "defaultAssociations": "1",
    "vendor": "ABUS Security-Center GmbH & Co. KG",
    "zwave_routing": "true",
    "zwave_beaming": "true",
    "zwave_secure": "false",
    "zwave_class_specific": "SPECIFIC_TYPE_NOTIFICATION_SENSOR",
    "zwave_devicetype": "2",
    "zwave_frequent": "false",
    "zwave_listening": "false",
    "manufacturerId": "0403",
    "manufacturerRef": "0002:0001",
    "dbReference": "1103",
    "zwave_deviceid": "1",
    "zwave_nodeid": "36",
    "zwave_lastheal": "2022-06-19T12:30:10Z",
    "zwave_plus_roletype": "ROLE_TYPE_SLAVE_SLEEPING_REPORTING",
    "zwave_manufacturer": "1027"
  },
  "UID": "zwave:device:gehirn:node36",
  "thingTypeUID": "zwave:abus_shbw10000_00_000"
}

This is pretty much the same, but with one difference: The decimal values are floats, not integers as before. This breaks one of my rules.

Hi, i have the same problem with openhab docker M7. some binding connected to the internet doesn’t work. Perhaps a problem with the docker image. I go Back to M6 and everything work again

Hi,

same here.
The bindings that want to go online get all the following errors:

2022-06-21 23:25:52.954 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'openweathermap:onecall:api:local' changed from OFFLINE (COMMUNICATION_ERROR): javax.net.ssl.SSLHandshakeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty to UNINITIALIZED

This could also be related to the errors mentioned by @partytown @phil2fer

Hello all,

Since 3.3.0.M7 the following message runs permanently. Everything works

2022-06-24 09:45:16.426 [INFO ] [io.openhabcloud.internal.CloudClient] - Disconnected from the openHAB Cloud service (UUID = e7a4eb54-373e-4952-a730-4004e2067edc, base URL = http://localhost:8080)
2022-06-24 09:45:29.352 [INFO ] [io.openhabcloud.internal.CloudClient] - Connected to the openHAB Cloud service (UUID = e7a4eb54-373e-4952-a730-4004e2067edc, base URL = http://localhost:8080)
2022-06-24 09:49:47.424 [INFO ] [io.openhabcloud.internal.CloudClient] - Disconnected from the openHAB Cloud service (UUID = e7a4eb54-373e-4952-a730-4004e2067edc, base URL = http://localhost:8080)
2022-06-24 09:49:54.538 [INFO ] [io.openhabcloud.internal.CloudClient] - Connected to the openHAB Cloud service (UUID = e7a4eb54-373e-4952-a730-4004e2067edc, base URL = http://localhost:8080)
2022-06-24 09:51:40.398 [INFO ] [io.openhabcloud.internal.CloudClient] - Disconnected from the openHAB Cloud service (UUID = e7a4eb54-373e-4952-a730-4004e2067edc, base URL = http://localhost:8080)
2022-06-24 09:51:46.814 [INFO ] [io.openhabcloud.internal.CloudClient] - Connected to the openHAB Cloud service (UUID = e7a4eb54-373e-4952-a730-4004e2067edc, base URL = http://localhost:8080)
2022-06-24 09:59:13.717 [INFO ] [io.openhabcloud.internal.CloudClient] - Disconnected from the openHAB Cloud service (UUID = e7a4eb54-373e-4952-a730-4004e2067edc, base URL = http://localhost:8080)
2022-06-24 09:59:19.995 [INFO ] [io.openhabcloud.internal.CloudClient] - Connected to the openHAB Cloud service (UUID = e7a4eb54-373e-4952-a730-4004e2067edc, base URL = http://localhost:8080)
2022-06-24 10:02:55.570 [INFO ] [io.openhabcloud.internal.CloudClient] - Disconnected from the openHAB Cloud service (UUID = e7a4eb54-373e-4952-a730-4004e2067edc, base URL = http://localhost:8080)

Greetings Holger

Remark for @Kai : the 3 new bindings mentioned as added in RC1 release notes were already there in M7. There is in fact no new bindings added with RC1.

2 Likes

I can finally confirm that problem has been solved with 3.3.0RC1

Just for the record, the config-duration values still have a fractional value like 255.0

Tip: as I had changed all channels previously to a different value than 255 I reverted this but this time I didn’t go through the UI each by each thing and channel but rather I edited the /var/lib/openhab/jsondb/org.openhab.core.thing.Thing.json file (stop OH, backup file, edit file, start OH). Make sure that you make a backup before editing.

Thanks for the fix
Stefan

3.3M7-> RC1 Upgrade seems to break HabPanel Dummy Items on older iPad 3

After upgrading from OH 3.3.0M7 Docker to RC1 Docker last evening I noticed that none of my Dummy Items are displayed in HabPanel running on an older iPad3. The issue does not exist with the M7. I have reverted to M7 and all is good, but if use the RC1 then issue is apparent. I can reproduce this going and back forth between the two versions, so I am fairly certain something changed in RC1 that is causing this issue. I have started and restarted the Docker several times to insure that everything settled, but to no avail. If I use an iPad 4 or newer, the issue is not present and it is only the Dummy Items that seem to have an issue.

From the release notes, this was merged:

Thanks for pointing this out. I missed that in the release notes. Unfortunately it turned out not to be a minor change for those of us running HabPanel on older hardware. I may be wrong, but I would imagine that includes a substantial percentage of HabPanel users.

I saw this exception this morning after installing the latest build (2972). I believe it coincided with me saving a change to conf/services/addons.cfg

2022-06-26 08:09:09.407 [WARN ] [mmon.WrappedScheduledExecutorService] - Scheduled runnable ended with an exception:
java.util.ConcurrentModificationException: null
	at java.util.HashMap.computeIfAbsent(HashMap.java:1135) ~[?:?]
	at org.openhab.core.service.WatchQueueReader.checkAndTrackContent(WatchQueueReader.java:439) ~[?:?]
	at org.openhab.core.service.WatchQueueReader.lambda$5(WatchQueueReader.java:355) ~[?:?]
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515) ~[?:?]
	at java.util.concurrent.FutureTask.run(FutureTask.java:264) ~[?:?]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:304) ~[?:?]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128) [?:?]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628) [?:?]
	at java.lang.Thread.run(Thread.java:829) [?:?]

Edit: To be a bit more specific, my change to conf/services/addons.cfg was to add a binding (unifi) to the list.

Thanks for the report, @mhilbush. I have created Fix ConcurrentModificationException in WatchQueueReader by kaikreuzer · Pull Request #3016 · openhab/openhab-core · GitHub for it.

2 Likes

Question: I’m still running on the M5. From the release notes I didn’t see anything that could break if I update directly to the latest milestone.
What you guys think?

Hi, I just updated from 3.2.0 to 3.3.0 on my integration system.
After that I received the following Error in openhab.log when opening habpanel or Refreshing MAIN UI Interface in Browser:

2022-06-27 09:17:16.902 [WARN ] [apache.cxf.jaxrs.utils.ResourceUtils] - No resource methods have been found for resource class javax.ws.rs.core.Response

The message is received 6 times.

Any Idea, what a can do?