openHAB 3.4 Milestone discussion

Seems to be related to jfrog repo is down.

I’d like to push all Smartmeter Add-On related topic for the next release.
There are a few open points on the bug tracker of Github:

The strangest thing is, that it was working perfectly until the end of 2020 - after that, there were a few changes made. Afterwards many users claim a connectivity error with their smart meter.
Actually I read-in all smartmeter things via USB and Node-Red. But I expect this as a central function inside a modern Openhab.

Moreover I’d like to start the discussion about integration of Viessmann viCare. All other smart home systems (ioBroker, Home Assistant) have the possibility to read-out and change parameters and live data of their heating unit.

How can I push these topics?

Hi there,

The Viessmann API binding I just released supports readout of data, I have not yet implemented write access (mainly because the ViCare app is sufficient for my own needs) but it may be in a forthcoming release especially if people ask for it.

I think there may also be another binding (SmartHome/J ??) that supports the API but I started this one before I discovered it and have not tried it.

I don’t support all the features yet as I only have a relatively simple heating setup but if there are people who have feature requests and are willing to test them out I am interested in hearing about them.

So I assume this was with OH2.x?
I also had problems with OH3 and the smartmeter-Binding. But since 3.3 everything works pretty good.
There were recently some changes done. See here:

There are some open issues on github, but they are all pretty old. So what problems are you facing?

Also the viessmann binding from smarthomej works very well.

I spotted a reproducible regression in M2. The Z-Wave binding is installed but not visible anymore in MainUI (in the console is shows up fine.) I suspect some additional effects as many links from zwave things to items disappeared.

Most visible error is that a new zwave thing cannot be selected anymore through the UI as zwave is not listed anymore in the “Choose Binding” menu. This can be circumvented however by typing “serverip:8080/settings/things/add/zwave” manually in the URL bar.

Perhaps I should report this on github, however I am not sure against which part of the code to report this bug (UI/Z-Wave/??).

It was fixed 6 days ago (PR #1805 reverting PR #1798)

1 Like

3.4.0.M3 - github only contains the source code, not the compiled files, so I can’t install

Tried to update my Windows 10 Install via Power Shell. Script however errors and closes the Power Shell Windows.

Was however able to capture the following:

Seems script cannot find the Milestone Build?

@moody_blue & @Mark_VG Please try again, the files are now also on Github. Sorry, I still have to get used to having to upload them there as well…


With the latest snapshot and a fresh installation I get

Launching the openHAB runtime...
Fehler: Hauptklasse Snap konnte nicht gefunden oder geladen werden
Ursache: java.lang.ClassNotFoundException: Snap

How can I fix it?

Do you mean with the latest milestone? It starts as expected for me and I have no clue what your error message might mean, sorry…

No - I mean the latest snapshot.


I realize this might have not been the appropriate thread to ask this question though …

this might have not been the appropriate thread to ask this question

Indeed, but to answer it nonetheless: Also the latest snapshot still works for me without issues…

It’s a non-issue.
I had a space in the folder name (3.4 Snap) and somehow this made problems :roll_eyes:
Once I renamed it to 3.4_Snap everything works again.


helllo, i’ve installed latest image of openhabian on RPI and worked, but after update to SNAPSHOT 3.4.0 i cannot login.
i reache the login page, but when i write username (admin) and password, it flash to the admin page but return to login page. tried everything but nothing worked for me…
any help for me?

thanks a lot

Seeing the same behavior here. openhab-3.4.0~S3124 updated this morning and can’t login now. Running it on a Rocky Linux 8.6 system. I reset the password using the console and still can’t login.

The log is showing:

2022-10-12 08:48:24.605 [WARN ] [uth.internal.AbstractAuthPageServlet] - Authentication failed from [ipv6 address]: Wrong password for user username

It’s a known error, please try this workaroud until it is fixed:

1 Like

Yep, added that and got webUI access again.