The Linux snapshot installation repo has moved!

General Note: To always find the latest installation instructions, please consult the official documentation. The following article will always be up to date:

Hi All,

Due to quota issues we have had to move our snapshots to a new repository! This should work exactly like the old repository (the GPG key is the same, so you don’t need to worry about that (Thanks @Theo!)). In order to move to it you simply need to:

echo 'deb unstable main' | sudo tee /etc/apt/sources.list.d/openhab2.list
sudo apt-get update
sudo apt-get upgrade

For everyone else, the Beta and the Stable builds will continue being hosted at Bintray!

As always please let us know if there are any issues in the openhab-linuxpkg github page.

Kind Regards,


Lots of Snapshot users of OH2! That’s great :slight_smile:

1 Like

worked like a charm. Last update on bintray was #789, just updated now to #791.

Nevertheless I get a TON of ERRORs after installing, but OH2 runs after that…

After updating from the first snapshot build that came with the rpi image, I get error 503 when starting and Add-ons and Rules catagories are gone in Paper UI. Is it possible to sovle? Got some bindings and things configured so would be happy if i don’t have to start over.

Edit: Now those menus are back, but sitemaps are still not loading though the file is still in sitemaps folder and the right name is in the UI configuration.

SOLVED! For some strange reason, one “}” was added in the end of the sitemap file, and I’m sure it wasn’t me since I turned on my lights this morning and haven’t edited the sitemap for a couple of weeks.

Just changed to new source and OH2 updated to Build 808.

But I see Cloudbee’s shows 811. How often is the new jfrog location updated?

On every successful build automatically :-). Build 809-811 failed to complete so the debian version stays the same.

Latest successful nightly is 6 days old.

Latest one now only 23 minutes old :wink:


Hello everyone,

I just tried to add the snapshot repository to my Raspian distro. Unfortunately somethings seems broken. Here is what I get during apt-get update.

Err unstable/main armhf Packages
302 Moved Temporarily

Any ideas?

Best regards

They seem to be all there. What is the exact line in your sources file?

Hello Benjy,

please see here:
straub@hab /etc/apt/sources.list.d $ cat openhab2.list
deb unstable main

1 Like

Seems the packages moved to https://

After changing the packet location and installing the https transport for apt (sudo apt-get install apt-transport-https), the source is now valid.

Now just the public key is missing.
W: GPG error: unstable Release: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 075721F6A224060A

That shouldn’t have been necessary, unless there’s something wrong dns side?

Have you added the gpg key to apt?

wget -qO - '' | sudo apt-key add -

Is there a changelog of the snapshot versions? Where can i find it?

Changes to openHAB are always done as pull requests to GitHub, if you know the date of your snapshot then you can find out what changes were made since that time. For example, a list of changes made since the release version of openHAB 2 (2017-01-23):

1 Like

I have the openhab2-offline snapshot repo installed, but when I understand it right this package won’t be updated anymore and I have to use the “normal” openhab2 snapshot package.
But I cannot I install the openhab2 package as long as the openhab2-offline is installed. And I don’t want to lose my configuration so I don’t want to uninstall openhab2-offline. Is there a migration path for this szenario?

No, you have to copy your conf folder (/etc/openhab2/), apt-get purge openhab-offline, change sources, apt-get update && apt-get install openhab2. After starting the new openHAB2 service, you are save to copy the old config files to /etc/openhab2/ (better per file, not the whole folder structure)

As there where changes belonging to the internal configuration (was changed from mapdb to json for speed reasons), there is no way to save the configurations, you made through Paper UI, so for this part, you will have to write down your configurations.
Please remember that openhab-offline was beta state, and the packaging was changed in beta phase.

Installing openhab2 will automatically remove openhab2-offline and replace it. I still recommend that you make a backup of the /etc/openhab2 and /var/lib/openhab2 directories first and if you’re using a much older version, be prepared to do any paperUI setup again.

At least on debian installing of openhab2 is not possible when openhab2-offline is installed. “apt-cache show openhab2” shows openhab2-offline and openhab2-online as conflicting packages:

Package: openhab2
Depends: adduser
**Conflicts: openhab2-online, openhab2-offline**

Because I’m using btrfs as filesystem type I created a snapshot as a fallback option and then did the following:

  1. Stop openhab2
  2. dpkg -r openhab2-offline (no purge)
  3. modify repository Information (now using stable repo)
  4. apt-get update
  5. apt-get install openhab2
  6. Start openhab2

To my surprise (nearly) everything seems to work well out of the box and my config survived, too.

The only thing that doesn’t work as expected is the key-based login to the karaf client, but I will open another thread for that topic.

Thanks for you input!

That’s strange, apt-get install on Debian 7 and 8 usually removes conflicts on install of similar packages. We tried to keep transitioning as simple as possible so I tested just this on my own machines. Glad you have the majority of it working though.