Android APP not updating Icons


i noticed recently that the icons in the Android App are not reflecting the actual state of the item, meaning if a light switch is OFF(item state also OFF) the bulb icon is still showing as ON. this seems to be for all my items.
however this seems only to happen if i’m connected to the remote link, local is fine.

i checked the basic UI via myopenhab and there everything is working fine.
I found only one reported problem in regards to the Roller-shutter, so if i missed one in regards to my problem, sorry.

otherwise, does anyone else is facing the same problem?

Android App: v2.0.0
Openhab lates stable version: 2.2


Just checked it with the Android App (same versions as above) from remote, WORKING for me.

hmm strange, installed the app on another android phone with the same results.
the item status gets changed but not the icon. :face_with_raised_eyebrow:

all other UIs are fine

I also have the problem in BascUI that after a change in the Items or Sitemap the autoupdate is stuck.
Then it helps to restart Openhab and it works again. Maybe same issue here?


i restarted openhab, and still the same behavior, as i already assumed.
right now i have no idea what’s the reason for this, everything seems to be ok except the icon update on the android app when i’m connected to the remote link (myopenhab). as soon as im at home and connected to the local server/link all appears correctly in the app.

I can confirm this or a similar issue with MQTT items accessed via myopenHAB from my iOS app, see
Incorrect item states via myopenHAB

1 Like

@Trickx is it for you that the state of the item is not reflecting correctly on myopenhab or only the icon?
because the state (switch) is showing as OFF in the android app for me but the icon is still showing as ON.
on myopenhab in all UIs its showing correctly.

1 Like

i just checked the same thing on another setup wit an older version of the 2.2 snapshot (#1073)
same result.
is it possible that this is related to the latest changes/updates of myopenhab?

i just added a basic sitemap and items to that environment, nothing fancy at all.

sitemap demo label="Main" {
    Frame label="Main" {

        Switch item=GF_Reception_Maindoow_Switch icon="light"
		Switch item=FF_Test_Switch icon="light"
Switch	GF_Reception_Maindoor_Switch		{channel="zwave:device:15ec7455983:node17:switch_binary1"}
Number	GF_Reception_Maindoor_Keyfob		{channel="zwave:device:15ec7455983:node18:scene_number"}
Number	GF_Reception_Maindoor_Keyfob_Batt	{channel="zwave:device:15ec7455983:node18:battery-level"}

Switch	FF_Test_Switch

I’m also using a 2.2 snapshot version of openHAB.
My issue seem to be related to the openHAB cloud configuration.
I just realized that I’m not able to enable some items being exposed to myopenHAB.
Some items’ checkboxes are not enabled in PaperUI.
When I try to enabled them, this settings is not storerd.
When re-loading the page, the item is again disabled.

ok did some more testing with always same results. i tested this now on 3 different openhabian installations 2 of them with the 2.2 stable and one with the lates 2.3 snapshot each time on 3 different Android phones.

always the same behavior, on remote connection the switch/state of an item is changing via the android APP but the Icon shows always ON.

does really nobody else is having the same behavior? :face_with_raised_eyebrow: :thinking:

Yes I’m having the same problem with a remote connection. I see incorrect icons and most of my charts do not display.

for me its now all of a sudden working again.

Still not working for me. In the screenshots below you can see the network icons are black (undefined) when using remote. If I clear the image cache from the app I usually get a different set of incorrect icons.



@digitaldan is this something to do with the myopenhab changes?

seems i was to fast, back to the same. but even clearing the icon cache is not changing anything for me.

this is how it looks for me. the location service icons should also show as OFF as for the local connection.
at both times the state is OFF.



I have the same problem with light icon. All my light icon are showed as on regardless of the switch status. If I click on the switch it work. My garage icon work correctly though. Using openhab cloud.

it was working smooth on my android phone when it was running on android version 6.0.1 however as I have updated to android version 7.1.1 whenever now I am opening the app it only loads a blank screen on the start up and crashes after a while automatically. How do I fix it ?

Hey @jasonsmith,
Sorry for the late answer, I haven’t seen your question. Do you still have this issue?

As of latest version, nothing update itself, I have to change page or do a refresh to see the change in the page. Like if someone open a light or if I press the open all button, all of my light doesn’t get open in the page, I have to hit refresh or switch group/frame page

This was an issue for me as well.
I’m having the same problem with a remote connection.
Did you ever find a resolution?

Can you post your items and sitemap files?